homestead_faq's profileBrand User

675 Messages

 • 

44.6K Points

Fri, Apr 17, 2020 3:35 PM

WebsiteBuilder: OG Image

WebsiteBuilder: OG Image

If you want to specify what image is used when someone shares/posts/likes your website on Facebook you can add this snippet of code to the tag:

<meta property="og:image" content="http://www.domain.com/image.jpg"/>


We need to replace the image url with the image you wish to use. 
Make sure you have already uploaded your image and published it.
Your picture will look best if it is square and at least 600 pixels wide
You just need to change the URL in the code to the address of the published image you want to use.
After you've added the code there and published you will need to run your website URL through the Facebook Debugger so they will crawl the site and make the update.

Facebook Debugger

To clarify, the code above will go into the Advanced settings in WebsiteBuilder . Even if there's other code in there already, that is ok.  Just scroll to the bottom of the existing text/code and then paste in the new code.  

  1. Add the image to an image gallery, place it anywhere on the page and publish the site. 
    (this gallery does not need to stay on the website, it will only display temporarily to get the image url)

  2. Visit the published site, open the image, right click on the image and select copy image address. 

  3. Paste this url into the code. Remove the current "url" and replace it with the info that was copied.
    <meta property="og:image" content="http://www.domain.com/image.jpg"/>

  4. Place the tag into the advanced settings. Under manage>advanced> site meta tags.

  5. Publish. Once you are finished you can remove the image gallery from the site.

7 Messages

 • 

122 Points

Il y a 13 d

Hi, I'm hitting a bit of a roadblock with the OG as well. The site is https://www.coolerbythecoast.com.

I've followed all of the steps in this article, but the FB Debugger still gives me the warning "The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags."

I have this as the site Meta tag: <meta property="og:image" content="https://cooler.homesteadcloud.com/x/cdn/?https://storage.googleapis.com/production-homestead-v1-0-1/041/940041/PPDGj7MZ/c9e77a3871494c08a9d4178f9d40f1a4"/>

But the site preview shows no image at all. I've been patient and waited some time after republishing the site before rescraping, but still no joy. Any suggestions for me to try next?

Thanks for your support!

Brand User

5.6K Messages

 • 

98.8K Points

Hello, 

This is because you don't have the domain pointing to the site properly. If you don't want to use nameservers, you can use DNS. Let me know if you need that option:

‎Account: Point a Domain to Homestead Using Nameservers | Homestead Community


7 Messages

 • 

122 Points

@elyzabethv​ Thanks for the speedy and helpful reply, Elyzabeth! I've added those nameservers as per that doc, and looks like the pointing is complete on the Homestead side. Still unable to complete the FB Debugger successfully, though. Is there anything else I should be looking for in the DNS records on my provider portal (Dotster)? Also, I have a domain pointer set up there of type URL Stealth, pointing to directory https://cooler.homesteadcloud.com - might this be causing some conflicts? Thanks for your help with my noob questions.

7 Messages

 • 

122 Points

One other observation: Since adding those nameservers, reachability for my domain has become very intermittent and unpredictable. I’m hoping that clears up, although it’s now been nearly 24 hrs. Thanks for any advice you can provide.

Brand User

5.6K Messages

 • 

98.8K Points

Yes, I would recommend removing the pointer, that should help. If it doesn't, please let me know and I'll see what else might be the issue. 

7 Messages

 • 

122 Points

When I remove the pointer, then my domain becomes unreachable. I put it back (as URL Standard, just to try it) and the URL is reachable again. It seems like adding the Homestead nameservers really messed things up - as if the Homestead and the Dotster nameservers don't agree on how to resolve my URL, if that makes sense.