B

4 Messages

 • 

110 Points

Saturday, January 6th, 2024 7:17 PM

YouTube Videos Will Not Load

After entering the URL in the dialog box for a YouTube video nothing happens. I have entered many videos before but maybe I am missing something. Is the YouTube video feature working?

Thank for your help,

Chris

This conversation is no longer open for comments or replies and is no longer visible to community members.

1.3K Messages

 • 

13.2K Points

4 months ago

Review the installation: INSERTING A VIDEO:

1. Select Insert > YouTube Video > copy and paste the URL into the YouTube Video Settings > Select play options, position and size > save and publish.


2. Select Insert > More > HTML > copy and paste the HTML code > position and size using HTML Settings > save and publish.

If you're uploading a *.mov file, this requires a Quick Time player to be on your computer to view the file, you can try converting it to another video format file. You can use this guide: https://community.homestead.com/homestead/topics/can_i_add_an_html5_video_to_my_site.


Have you tried to use the YouTube embed code when using the HTML option?
https://community.homestead.com/homestead/topics/can_i_add_an_html5_video_to_my_site.


I recommend adding the video via YouTube.

(edited)

4 Messages

 • 

110 Points

Hi Russell:

Thanks for your suggestions. I converted a .mov video from my iPhone to a YouTube video and it is the YouTube video that I am trying to insert. I have done it many times on the website, www.delawareseasiderailroadclub.com but this time nothing happens once I paste the YouTube URL into the dialog box. Also, previously a video player was inserted as a frame and then the YouTube URL played from it under preview. Now the video player doesn't get loaded. When I try to insert a video player I just get a dialog box to insert files. It seems like something is mission or the online software has gotten corrupted. 

1.3K Messages

 • 

13.2K Points

@bill0619​ Are you using SB+ or websitebuilder? If you're using SB+, review these instruction on adding media files.

https://community.homestead.com/conversations/sitebuilder-plus/sitebuilder-plus-add-media-files/5f2a9b3958180958845ec112

Did you try both methods using the embed method as well as the YouTube address method?

note: This site doesn't load:

https://www.delawareseasideraiulroadclub.com/

4 Messages

 • 

110 Points

I am using Sitebuilder Plus. I think I discovered what the problem is. When I send my iPhone videos to YouTube they now get automatically converted to YouTube "shorts". Previously they were just short length videos. I can insert a YouTube video with the player but not a "short". Apparently this Sitebuilder Plus software does not allow "shorts". My next question is how on YouTube can you create a video and not a short. I haven't found any commands or selections on YouTube in which you can select video or short.  

1.3K Messages

 • 

13.2K Points

I looked up your question using google. This is what I saw:

"Make sure the video is 16:9. If the video is horizontal(landscape) it won't be considered a Shorts video. One major requirement for a YouTube Shorts is that it needs to have a 9:16 dimension."

Link: https://www.quora.com/How-can-I-post-a-video-less-than-1-minute-to-YouTube-but-not-get-it-flagged-as-a-short#:~:text=Make%20sure%20the%20video%20is,have%20a%209%3A16%20dimension.