C

3 Messages

 • 

92 Points

Tuesday, January 9th, 2024 5:31 PM

How do I fix this: Gmail requires all senders to authenticate with either SPF or DKIM.

Gmail requires all senders to authenticate with either SPF or DKIM. I am having this problem with my claire@clairefadden.com email address. Emails sent to Gmail accounts bounce back.  How can I fix this?

    host gmail-smtp-in.l.google.com [172.253.63.26]

    SMTP error from remote mail server after end of data:

    550-5.7.26 This mail has been blocked because the sender is unauthenticated.

    550-5.7.26 Gmail requires all senders to authenticate with either SPF or DKIM.

    550-5.7.26

    550-5.7.26  Authentication results:

    550-5.7.26  DKIM = did not pass

    550-5.7.26  SPF [clairefadden.com] with ip: [66.96.189.5] = did not pass

    550-5.7.26

    550-5.7.26  For instructions on setting up authentication, go to

    550 5.7.26  https://support.google.com/mail/answer/81126#authentication pr1-20020a056214140100b006800eced41asi108195qvb.614 - gsmtp

This conversation is no longer open for comments or replies and is no longer visible to community members.

Brand User

10.5K Messages

 • 

141.3K Points

3 months ago

Hello, 

Can you go ahead and try once more? I have updated the TXT SPF record for your domain which should allow it to begin working properly.

5 Messages

 • 

130 Points

@elyzabethv​ Can  you please send me the SPF info as well.  Just trying to send as my custom domain sender from gmail.  Can't send to gmail addresses

3 Messages

 • 

92 Points

3 months ago

Thank you Elyzabethv.  Everything is working now. I appreciate you.

2 Messages

 • 

122 Points

3 months ago

Elizabeth, I'm having the same issue for shawn@shawn-hamilton.com

Brand User

10.5K Messages

 • 

141.3K Points

Hello Shawn, 

The first step in troubleshooting would be to check your DNS. Since your nameservers are pointing to Cloudflare, I cannot fix it for you. Please log into that account and make sure your email DNS matches what's in that article exactly:

‎DNS Records for Homestead Email | Homestead Community

8 Messages

 • 

130 Points

3 months ago

We are having same problem sending emails from our domain (@mulfordgardens.org). Our homestead website uses that domain and has several email accounts, e.g. admin@, treasurer@, events@.

This error appears when we send to a gmail account, in this case mgiaevents@gmail.com. We get this error;

Mail delivery failed: returning message to sender
Gmail requires all senders to authenticate with either SPF or DKIM

8 Messages

 • 

130 Points

This issue is resolved for me. I contacted techs support and they resolved by updating the TXT record on the advanced DNS settings for my domain. This is what they added:

v=spf1 ip4:66.96.128.0/18 include:websitewelcome.com ?all

This is also explained in the email setup article from homestead.

21 Messages

 • 

462 Points

3 months ago

@elyzabethv  - I am having the same situation!  Sent email from leann@astresslesstransition.com to leannmooretpa07@gmail.com and it's now in Never-Never Land.  No undeliverable message.  No bounce back.  I've had several clients with gmail accounts say email never received.  Please help!  I'm losing business because of this.

(edited)

8 Messages

 • 

130 Points

3 months ago

I had a similar problem with gmail accounts and called homestead tech support and Alan was quite helpful.  Gmail requires an SPF or DKIM authentication. For SPF, you can edit the advanced DNS settings for your domain. Go to the TXT section and that should look like this: 

v=spf1 ip4:66.96.128.0/18 include:websitewelcome.com ?all

This is explained in the email setup article in homestead.

3 Messages

 • 

80 Points

3 months ago

I am having the same problem:  emails sent from my Homestead email server to gmail addresses are being bounced back.  I have set the SPF code in the homestead advanced settings to at TXT record of "v=spf1 include:_spf.google.com ~all", as per the google instructions for setting up email authentication, however this has not solved the problem.  I continue to get a bounce back message of the form below.

Please advise how to fix this problem soonest.  Thank you.

________________________________________________________________________________________________

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

 

    host gmail-smtp-in.l.google.com [172.253.122.26]

    SMTP error from remote mail server after pipelined end of data:

    550-5.7.26 This mail has been blocked because the sender is unauthenticated.

    550-5.7.26 Gmail requires all senders to authenticate with either SPF or DKIM.

    550-5.7.26

    550-5.7.26  Authentication results:

    550-5.7.26  DKIM = did not pass

    550-5.7.26  SPF [retrouvaillecalgary.com] with ip:

    [66.96.184.2] = did not pass

    550-5.7.26

    550-5.7.26  For instructions on setting up authentication, go to

    550 5.7.26  https://support.google.com/mail/answer/81126#authentication t3-20020a0cde03000000b0067f9d0c7fedsi770681qvk.360 - gsmtp

11 Messages

 • 

360 Points

3 months ago

I have the same or similar problem!  My e-mails do not reach one particular corporate client.  Here's what this client IT person told me:  "We're getting an error when they send us e-mails "SPF Sender Invalid".  SPF records protect against malicious emails that attempt to perform email spoofing.  It's captured by a spam filter that checks the SPF record. Which is what happened here."

Thus, it's a "SPF Validation Error" or "SPF Sender Invalid" headline.

It would be great if you can help ... thank you!

11 Messages

 • 

360 Points

Good news; I did fix the problem by reading previous comments to alter the DNS text.  I modified the single line in my settings to the recommended "v=spf1 ip4:66.96.128.0/18 include:websitewelcome.com ?all" 

The recipient who had not gotten e-mails over the past few days now receives my e-mail.

2 Messages

 • 

122 Points

I am not real familiar with this stuff, where do I go to update that text?

3 Messages

 • 

80 Points

Hi Joseph8192.  Thanks for the update.  However I have tried adding that exact text string into my DNS TXT Records settings  ie:  "v=spf1 ip4:66.96.128.0/18 include:websitewelcome.com ?all" ,  and my emails from Homestead are still being rejected by gmail recipients.

Question:  do you have other DNS TXT Records setting lines, or just the single line entry?

11 Messages

 • 

360 Points

@shawn6206​ When I log in to Homestead, my screen shows a list running down the left side with "Getting Started" then "Websites Manager" then "Domains" and so on.  Click "Domains".  On that screen, look for "Advanced DNS Settings" (lower right).  Click that.  At the bottom of this screen (for me, at least), I see "TXT Records".  There's only one entry (a Name and Value).  Edit that Value entry to what I had written by first clicking the "Edit" button near the top of the screen.

11 Messages

 • 

360 Points

@brian3669​ Before editing, I had just one line. That existing line was similar to the new, suggested line. So I changed the old line to the new line (again, "v=spf1 ip4:66.96.128.0/18 include:websitewelcome.com ?all").  After the edit, I still have just the one line.  BUT NOTE, I had just one corporate client tell me it did not receive my e-mails.  (And now they say it's fixed after I edited the text here.)  I wonder if "gmail" could be a distinct problem.  I had the gmail problem more than a year ago and one of the Homestead techs fixed that somehow.