Why is my page password protected when I didn't add it?

  • 3
  • 19
  • Question
  • Updated 2 months ago
  • Answered
If you have a page that has become password protected and you never added the password, then it is because the password has been save in your browser and the browser is adding it to the field. When you save the page and publish, the browser has added the password to the page and it goes online. You will need to enter the password manager of the browser and locate the line for "sitebuilder.homestead.com" and remove it from the list.

Chrome

1) Go to Settings and scroll down to the bottom and click Advanced.



2) Scroll down to the Password section and click on Manage passwords



3) Find the Website sitebuilder.homestead.com and remove it.




Firefox

1) Open Options and click Security, then Saved Log ins. Then search for sitebuilder.homestead.com and remove it.






This should prevent this from happening again.
Photo of Drew N

Drew N, Community Manager

  • 256,782 Points 100k badge 2x thumb

Posted 11 months ago

  • 3
  • 19
Photo of Fred6863

Fred6863

  • 140 Points 100 badge 2x thumb
Thanks, Drew. I did unsuccessfully search for something on the topic but didn't see the post you shared with me. I followed your instructions, removing passwords for sitebuilder and my own website www.hphs1967.com. It's interesting that a Chrome setting can change an advanced setting within Homestead's sitebuilder. 
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
I agree, but the password manager in the browser is designed to detect a field for passwords and enter the saved data to make life easier for the user. Unfortunately, sometimes it puts it in places that it doesn't belong. We have developers looking to see if this can be blocked so that it doesn't populate that field even if there is a password. I am not sure if it can be, but this should fix it until such a time as we find out.
Photo of Stan0332

Stan0332

  • 96 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Site now requires viewers to have a password to see the site, when before it wasn....

Why is my site is now requiring a password for those that want to see it. It hasn't been that way prior to today. It is the same password as I need to log in, but I'd rather not have to have my parents have access. They need to be able to see it without a password.
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
This should be the resolution to the issue.

I am sorry if I didn't get this info to you earlier.
Photo of Martin

Martin

  • 5,340 Points 5k badge 2x thumb
This whole password protected issue seems to be getting worse. I tried the usual workaround today......several times. Finally had to log off and back on to get it to work. Contact page was password protected for ~ 10 minutes or so, this is not good!
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
Martin, the only cause we can find for this is in the main post here and you can fix it by remove the stored password for sitebuilder.homestead.com
Photo of Martin

Martin

  • 5,340 Points 5k badge 2x thumb
Got it, my "workaround" was different, this seems to have fixed it. I should pay better attention, thanks.
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
No problem.
Photo of James8015

James8015

  • 272 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Should not have a password on the page..

Me too! I've been getting a random "password request" field after I publish a page. When I go back to view the Advanced Page Settings to check it out, there's a password entered into the field that I did NOT put there. Just experienced that with a page now and thought I handled it, but then when I go to view the published URL for my page, I get "page cannot be found." It's one thing to hit a target and handle it, but when the gremlin keeps moving around, it's extremely frustrating.

Note: This conversation was created from a reply on: SITEBUILDER.
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
James8015, you should be able to solve this by removing the saved password in your browser.
Photo of James8015

James8015

  • 272 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Should not have a password on the page..

Me too! I've been getting a random "password request" field after I publish a page. When I go back to view the Advanced Page Settings to check it out, there's a password entered into the field that I did NOT put there. Just experienced that with a page now and thought I handled it, but then when I go to view the published URL for my page, I get "page cannot be found." It's one thing to hit a target and handle it, but when the gremlin keeps moving around, it's extremely frustrating.

Note: This conversation was created from a reply on: SITEBUILDER.
Photo of Jim5530

Jim5530

  • 706 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Unwanted 'password protected' added to the 'special features..

When I adjust a page and publish I find the software has added password protection to the 'special features' which obviously blocks viewers from that page. Until now it has been annoying but removable, now I find I cannot not remove it.
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
What site and exact page name? This will prevent it from happening again, but if you can't remove it, I can take a look.
Photo of Jim5530

Jim5530

  • 706 Points 500 badge 2x thumb
Hi Drew
The most recent was at http://midgebuilders.homestead.com/Breaking-news.html but I think I have stopped it after deleting some of the chrome passwords that I thought were allowing me to access sitebuilder. It was a community suggestion that put me onto that train of thought, I had been trying to reach it from the advanced page properties on sitebuilder rather than chrome. I also removed the automatic chrome password on my computer from the one page that should have a password. One of those actions seems to have solved it. I have to write in the password manually, but that is ok. If the bug was caused by chrome then they must have changed something recently which made the occasional problem worse. Hopefully the matter is now resolved. Thanks for your attention.
Photo of dwightokita

dwightokita

  • 394 Points 250 badge 2x thumb
Drew, you're a lifesaver.  I've had this issue for about a year.  No one at Homestead could help me when I called.  But luckily I searched help again and this seems to have fixed it!
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
Happy to help. I can tell you it was very difficult to track down.
Photo of Alexander3497

Alexander3497

  • 224 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Website is not coming up Please help.

Website does not come up after wcm changes saved and publish.
password required and goes to homestead in 10 secs.  Urgent!  This is the 3rd time. I call help but they are closed now.  Have to get the site up tonight.
Photo of Since7380

Since7380

  • 112 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled One pages resets to password needed everytime I update it.How do I stop this from....

everytime I update one of my pages the status online changes to password needed to access, then I have to go back and cancel the password needed...does this everytime. How do I stop this from happening. 
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
MIGRATING PASSWORD:
I am experiencing the same problem ever since I added a password protected page. I have deleted it from each page and have deducted that the password migrates to whatever page I exit from. Create a dummy page, an unlisted page, and use for exiting your website editor. This practice will eliminate that problem with your published site.
Photo of Jim8115

Jim8115

  • 282 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled Get rid of log in on home page of my site.
Photo of Since7380

Since7380

  • 112 Points 100 badge 2x thumb
Its not saved in the browser and I have cleared it but what is happening is this:
I go to the link to add a password and delete the password. Upload the new page and its fine. Then I return to update the page reload the new information and it automatically adds the password protection back on. So now every time I update the page I have to go and delete the password protection.
(Edited)
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
We have not seen any other way that this can happen. sitebuilder.homestead.com must have a saved password in the browser. Potentially if you use some other password manager with auto fill options, that may do it too.
Photo of Jim8115

Jim8115

  • 282 Points 250 badge 2x thumb
I went to chrome at settings and removed now the password is gone yet still mants log in
Photo of Jim8115

Jim8115

  • 282 Points 250 badge 2x thumb
It finally worked... thanks
Photo of Deborah3557

Deborah3557

  • 122 Points 100 badge 2x thumb
This was happening to me as well. I had to go into my settings in chrome, and turn off auto fill password for the homestead site. I found this on one of the replies to someone else's question.
Photo of dwightokita

dwightokita

  • 394 Points 250 badge 2x thumb
This worked for me too.  Thanks.
Photo of Virginia2266

Virginia2266

  • 202 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled two of my pages revert to password protection even after I save them with the jav....

two of my pages revert to password protection even after I save them with the javascript box and password boxes deleted. How can I permanently delete all necessity for passwords?
The two pages are index and kenya on leavingfootprints.org Thanks
Photo of Darcy6850

Darcy6850

  • 112 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled How do I remove a password from a page I accidentally added.

I was editing a page and It would not load, I though my partner may have added a password so I entered the password that we normally use. don't know if it was coincidence but the page loaded and I went ahead with the edit. But found after I published it it would not show up unless I entered the password. Please Help. I need that page
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
Drew N Community Manager profile pictureDrew N (Community Manager) just asked this question in Homestead(Sitebuilder Plus):
Why is my page password protected when I didn't add it?
If you have a page that has become password protected and you never added the password, then it is because the password has been save in your browser and the browser is adding it to the field. When you save the page and publish, the browser has added the password to the page and it goes online. You will need to enter the password manager of the browser and locate the line for "sitebuilder.homestead.com" and remove it from the list.

Chrome

1) Go to Settings and scroll down to the bottom and click Advanced.



2) Scroll down to the Password section and click on Manage passwords



3) Find the Website sitebuilder.homestead.com and remove it.




Firefox

1) Open Options and click Security, then Saved Log ins. Then search for sitebuilder.homestead.com and remove it.






This should prevent this from happening again.
Photo of Sheilla8233

Sheilla8233

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Password puts itself on non password protected pages.

I have 1 tab on my website that is password protected. But all of a sudden the website manager has placed the password on random tabs on the website. Even when I go on and remove them they show back up. I am the only person that has access to the website manager for this site. HELP! This has been happening for a week now. And I've fixed it multiple times. website is www.kc4-hhorse.com it shows up on random pages. Even after I've fixed it then saved and published it.
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
MIGRATING PASSWORD:
I experienced the same problem ever since I added a password protected page. I have deleted it from each page and have deducted that the password migrates to whatever page I exit from. Create a dummy page, an unlisted page, and use for exiting your website editor. This practice will eliminate that problem with your published site.
Drew N Community Manager profile pictureDrew N (Community Manager) just asked this question in Homestead(Sitebuilder Plus):
Why is my page password protected when I didn't add it?
If you have a page that has become password protected and you never added the password, then it is because the password has been save in your browser and the browser is adding it to the field. When you save the page and publish, the browser has added the password to the page and it goes online. You will need to enter the password manager of the browser and locate the line for "sitebuilder.homestead.com" and remove it from the list.

Chrome

1) Go to Settings and scroll down to the bottom and click Advanced.



2) Scroll down to the Password section and click on Manage passwords



3) Find the Website sitebuilder.homestead.com and remove it.




Firefox

1) Open Options and click Security, then Saved Log ins. Then search for sitebuilder.homestead.com and remove it.





This should prevent this from happening again.
Photo of Jim5530

Jim5530

  • 706 Points 500 badge 2x thumb
That sorted it for me, My computer is a mac and use Chrome, so to get to settings I click on the word Chrome at the top left, go through preferences to settings. Then as Drew explains above. Haven't had any problem since. I would say this is a problem with Chrome Firefox etc, but it might be a good idea if Homestead put a note on the advanced settings part of the 'Page Settings' to indicate that because of the software clash it is inadvisable to let your web browser (Chrome, Firefox etc) save homestead individual page passwords. Incidentally, I haven't had any trouble with Chrome saving the password I need to get into sitebuilder, just the individual pages.
Photo of Alexander3497

Alexander3497

  • 224 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Unwanted log in requirement.

After saving and publishing updates and changes to website pages, log in requirement prevents getting to site.
I've had this problem before (2 months ago). I can't remember or find the help that got it fixed.
Photo of Brigitte8910

Brigitte8910

  • 142 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled How to delete the password protecting a page ?.

I have one page on my website protecting by a password. But when I publish my website, the password seems to apply to all the pages (or some randown pages at least) even if I try to erase it in the advanced setting.
What can I do ?
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
Brigitte8910, You have to manually remove the password from each page you don't want it, but check out this topic first as it will stop it from happening in the future.
Photo of Hugh

Hugh

  • 1,086 Points 1k badge 2x thumb
Hi Drew N,
Re: https://community.homestead.com/homestead/topics/why-is-my-page-password-protected-when-i-didnt-add-...

I had not had this problem before, but just as of last week after making changes to one page. Visitors to my site are being asked for a Password on Sunday's Meetings.

I went through your detailed process for Chrome and then tried Monday's Meetings and also for Memorials (the 3rd page) and now all 3-pages require a Password.

In the Chrome Browser, I have removed a number of homestead passwords (all of them including "sitebuilder.homestead.com") from the list.

I am not fond of asking for help, but it seems I am only adding more pages to the list as I try to correct the problem. I see you must have done something for Jim5530 because I checked his site and there is not a “Request for a Password”

Hoping you could do the same for me – www.aalondon.org

Hugh

Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
The only method that we can see to cause this is by having the password stored in your browser. Once that is removed, then you remove the password from the page and it should not return. If it does, then the password is still stored in the browser. We have spent quite a bit of time looking at this, and for everyone so far it has resolved the issue. We have never found anything that would indicate another cause or something we can fix.
Photo of Hugh

Hugh

  • 1,086 Points 1k badge 2x thumb
Thanks for everyone's help here
Photo of Hugh

Hugh

  • 1,086 Points 1k badge 2x thumb
Here again - I did everything that Drew put up in as Screen Shots as to removing these passwords
I started with an dummy website and made an EXIT PAGE and worked with not problem
Then went to the site that I wanted to edit - made an Exit Page and then did my editing on about 8 or 9 pages - went back to the Exit Page and Publish All the Site but one page came and ask for a Password, and do not know how to remove it - the page is > http://www.aalondon.org/Newsletter-Unity-London.html
I would like any help you can give me
Hugh
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
Use Page Settings > Advanced Page Settings > Remove the password > Save and Publish. Exit the program from your dummy page.

Drews advise: If you have a page that has become password protected and you never added the password, then it is because the password has been save in your browser and the browser is adding it to the field. When you save the page and publish, the browser has added the password to the page and it goes online. You will need to enter the password manager of the browser and locate the line for "sitebuilder.homestead.com" and remove it from the list.
Chrome:
1) Go to Settings and scroll down to the bottom and click Advanced.
Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1630121/12868-vmlgk4_inlinepng1501706787
2) Scroll down to the Password section and click on Manage passwords
Image: https//d2r1vs3d9006apcloudfrontnet/s3_images/1630122/952-jnly4o_inlinepng1501707158
3) Find the Website sitebuilder.homestead.com and remove it.
Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1630123/5151-4i3s1s_inlinepng1501707196

Firefox:
1) Open Options and click Security, then Saved Log ins. Then search for sitebuilder.homestead.com and remove it.
Image: https://d2r1vs3d9006ap.cloudfront.net/s3_images/1630124/5151-1mvtcve_inline.png?1501707386

This should prevent this from happening again.
(Edited)
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
I removed the password, but if you removed the info according to the instructions above this should not happen. There could be a second instance saved in there. You could try a different browser too.
Photo of themieleman

themieleman, Champion

  • 54,684 Points 50k badge 2x thumb
MIGRATING PASSWORD:
I assume it is one of the Sitebuilder sites. Please read this topic, https://community.homestead.com/homestead/topics/why-is-my-page-password-protected-when-i-didnt-add-....
I experienced the same problem ever since I added a password protected page. I have deleted it from each page and have deduced that the password migrates to whatever page I exit from. Create a dummy page, an unlisted page, and use for exiting your website editor. This practice will eliminate that problem with your published site.
(Edited)
Photo of Tim0996

Tim0996

  • 92 Points 75 badge 2x thumb
Followed procedure and still asked to enter password when trying to access my web site. Please advise.
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
Did you delete your password from the homepage? Save and Publish. Exit you editor from a dummy page.
Photo of Tim0996

Tim0996

  • 92 Points 75 badge 2x thumb
Got it! Thanks
Photo of Martin

Martin

  • 5,340 Points 5k badge 2x thumb

Drew, anyone at Homestead? Please, this is an ongoing problem that many of us are sick and tired of.  I have done all of the work arounds..etc.. I just published a page and followed all of the instructions.

There is no reason we should have to fix and deal with ad infinitum  Can you all please fix this problem.


Thanks!

(Edited)
Photo of themieleman

themieleman, Champion

  • 54,284 Points 50k badge 2x thumb
It is a browser peculiarity, not a Homestead program systems error. These are the instructions for eliminating the password:
"If you have a page that has become password protected and you never added the password, then it is because the password has been save in your browser and the browser is adding it to the field. When you save the page and publish, the browser has added the password to the page and it goes online. You will need to enter the password manager of the browser and locate the line for "sitebuilder.homestead.com" and remove it from the list.
Chrome:
1) Go to Settings and scroll down to the bottom and click Advanced.
Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1630121/12868-vmlgk4_inlinepng1501706787
2) Scroll down to the Password section and click on Manage passwords
Image: https//d2r1vs3d9006apcloudfrontnet/s3_images/1630122/952-jnly4o_inlinepng1501707158
3) Find the Website sitebuilder.homestead.com and remove it.
Image https//d2r1vs3d9006apcloudfrontnet/s3_images/1630123/5151-4i3s1s_inlinepng1501707196

Firefox:
1) Open Options and click Security, then Saved Log ins. Then search for sitebuilder.homestead.com and remove it.
Image: https://d2r1vs3d9006ap.cloudfront.net/s3_images/1630124/5151-1mvtcve_inline.png?1501707386

This should prevent this from happening again."
Photo of Martin

Martin

  • 5,340 Points 5k badge 2x thumb

Can you not comprehend the English language? I am sick of the workarounds....

Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
Martin, this is not a workaround. Developers have spent hours and there is nothing in our programming that can do this. Somewhere in your browser is a saved login that is putting it in there. Can you try a different browser? If you don't save the login, I will bet it doesn't happen.
Photo of Jim5530

Jim5530

  • 706 Points 500 badge 2x thumb
  I am happy with Homestead and intend to keep with it, however I agree that this bug could be improved. Perhaps Homestead could put a reminder below the password option box stating that 'saving' the password may cause this problem.
  I know of some sites where the password will not save, perhaps because of the same bug. I wouldn't want to trigger a large rise in expense / fees, but there are a few bits of rather elderly software causing at least one reviewer to refer to Homestead as a dinosaur.
  In their defence I would agree that the dinosaurs survived millions of years and only failed (largely) because of a perfect storm of challenges, but perfect storms do happen... perhaps it is time for a bit of preparation.
  Getting back to the point the fault seems to be well defined, don't let the browser store the password, surely it cannot be beyond the wit of man to put an advisory on the password option box?
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
I am not sure if this can be done for sitebuilder.homestead.com specifically and not for Homestead as a whole. It might prevent saving information for the main account and possibly email addresses. It is worth investigating though.
(Edited)
Photo of Mark8984

Mark8984

  • 302 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled removing password from domain.

When I go to my website, it is asking me for a password. I followed the guided suggestion on the form but, the password is still being requested.
Photo of Drew N

Drew N, Community Manager

  • 256,162 Points 100k badge 2x thumb
You must have a password set as this topic describes. Remove that, then go to the page in the editor and remove the password from the page itself. After that, publish.
Photo of staceykuehner1839

staceykuehner1839

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled How do i get rid of the password protection.

I added a password to one of my pages and it i now on other pages as well. Now i wanted to get rid of it and it wont let me
Photo of Drew N

Drew N, Community Manager

  • 255,898 Points 100k badge 2x thumb
staceykuehner1839, Please read this topic at the top to remove the reason the password added and remove it, then you will need to go manually remove the password from the desired pages.