WebsiteBuilder: Specify the Image Used by Facebook for Shares and Likes

  • 0
  • 1
  • Article
  • Updated 2 weeks ago
Hello,

If you want to specify what image is used when someone shares/posts/likes your website on Facebook you can add this snippet of code to the tag:

<meta property="og:image" content="http://www.domain.com/image.jpg"/>

We need to replace the image url with the image you wish to use. 
Make sure you have already uploaded your image and published it.
Your picture will look best if it is square and at least 600 pixels wide
You just need to change the URL in the code to the address of the published image you want to use.
After you've added the code there and published you will need to run your website URL through the Facebook Debugger so they will crawl the site and make the update.

Facebook Debugger

To clarify, the code above will go into the Advanced settings in WebsiteBuilder . Even if there's other code in there already, that is ok.  Just scroll to the bottom of the existing text/code and then paste in the new code.  



1. Add the image to an image gallery, place it anywhere on the page and publish the site. 
(this gallery does not need to stay on the website, it will only display temporarily to get the image url)

2. Visit the published site, open the image, right click on the image and select copy image address. 

3. Paste this url into the code. Remove the current "url" and replace it with the info that was copied. 

<meta property="og:image" content="http://www.domain.com/image.jpg"/>

4. Place the tag into the advanced settings. Under manage>advanced> site meta tags. 

5. Publish. Once you are finished you can remove the image gallery from the site.
Photo of Homestead FAQ

Homestead FAQ, Employee

  • 43,386 Points 20k badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of ToycrafterDave

ToycrafterDave

  • 60 Points
I followed these directions. I got this warning from Facebook: Provided og:image URL, https://storage.googleapis.com/wzsitethumbnails/site-49484794/800x500.jpg could not be processed as an image because it has an invalid content type.

Photo of Michelle C

Michelle C, Employee

  • 28,812 Points 20k badge 2x thumb
That may be the incorrect image address. It should reference a photo when the link is clicked on.
What page is this image published to on the site? I can take a look. 
Photo of Jonathan T.

Jonathan T.

  • 6,604 Points 5k badge 2x thumb
What's the easiest way to track down the image link? I was also having the same issue as above.
Photo of Michelle C

Michelle C, Employee

  • 28,812 Points 20k badge 2x thumb
Odd, I can try to extract the URL, that does look a little different than it usually would. What image do you want to use and what site is it on?
(Edited)
Photo of Michelle C

Michelle C, Employee

  • 28,812 Points 20k badge 2x thumb
It is entered correct. The warning message can be disregarded. When I test the debugger it shows the correct image.


Also, when I go to share the link it shows the correct image as well. It is good to go. 

Photo of Jonathan T.

Jonathan T.

  • 6,604 Points 5k badge 2x thumb
Thank you