Skip to main content
Brand User

655 Messages

 • 

44.2K Points

Tue, Aug 21, 2018 11:40 PM

Sitebuilder Plus: Google Analytics

Sitebuilder Plus: Google Analytics
To set up Google Analytics:

  1. Go into Websites Manager and click where it says "Integrate Google Analytics Get Started"





  2. Click "Sign Up"




  3. Choose Website and enter the Account Name you choose, your Website Name, and your URL. Uncheck any of the boxes you don't want and click Get Tracking ID.







  4. We strongly recommend you read the term and conditions. To continue you must accept the terms of service by checking the boxes. If you agree, click I Accept.




  5. Next, you'll need to copy the Tracking ID and paste it in your Homestead Account in the "Integrate Google Analytics" window and Save it. Then click "Go to Sitebuilder Plus"




  6. Then copy the Global Site Tag from the Analytics account, and paste it in Page Settings > Advanced Settings head tag HTMLPublish your site. 





  7. Now you will be able to click on View Stats and it will bring you into Google Analytics. 



Responses

2 Messages

 • 

132 Points

2 years ago

This reply was created from a merged topic originally titled can't find out how to add google analytics.

self explanatory
Brand User

634 Messages

 • 

50.3K Points

Hello,

Here are the instructions for setting up Google Analytics.

51 Messages

 • 

1.7K Points

2 years ago

I can't locate the ""Integrate Google Analytics Get Started" button.  Where can I find it.  
"
Brand User

634 Messages

 • 

50.3K Points

You're using Website Builder, not Sitebuilder Plus. These instructions do not apply to you.

https://community.homestead.com/homestead/topics/google-analytics-website-builder

17 Messages

 • 

540 Points

On my Websites Manager page, it has no box for starting Google Analytics, and there is no heading that says Website Builder or Sitebuilder Plus. My site is still in Sitebuilder Plus - I haven't started building the new one in Websitebuilder yet. How do I start Google Analytics?
Brand User

2.9K Messages

 • 

60.7K Points

Hello,

It looked like the account was set up awhile ago and at one point you may have been using Sitebuilder desktop which is what it was reflecting and is why you didn't see that option. Since you did mention you are using Sitebuilder plus and I am able to see and confirm that, I went ahead and made a slight adjustment in your account. You are now able to see the get started button for google analytics. Let me know if you see it on your end.

17 Messages

 • 

540 Points

I did what you said to do, but was not allowed access. "Missing permissions. You don't have access to the account. Contact an Analytics Administrator who has a Manage Users position." Wouldn't generate a tracking number. When I clicked on the link to Google instructions, I got the same message.
Brand User

2.9K Messages

 • 

60.7K Points

If you are see the missing permissions pop up it means you are logged into a google account that cannot be linked with google analytics (possibly a work one). Try logging out of whatever google account you are signed into or try using an incognito window (ctrl+shift+N) this should resolve that pop up and allow you to continue to generate a tracking code.