Why does my website domain shows .homestead.com in the domain instead of my domain name only?

  • 0
  • 1
  • Problem
  • Updated 9 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archiving inactive content

Photo of Hubert6484

Hubert6484

  • 160 Points 100 badge 2x thumb

Posted 9 months ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
Hello,

You've directed your domain to itself, which is creating a loop where your domain isn't actually pointing anywhere. I will correct this for you.
Photo of Terry9448

Terry9448

  • 90 Points 75 badge 2x thumb
Elyzabeth, my website has been nnnnn.homestead.com since I inherited it from the previous webmaster 11 years ago. It seems to work fine.  Should the homestead portion not be there? If I change it to nnnn.com, seems that will throw off the saved site address of countless people.  I have always assumed that it was the way Homestead sets it up.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
It sounds like your webmaster from 11 years ago, for some reason, opted to not use a domain name. Using a domain is better for branding, so it is recommended to have one, but with your site I would recommend keeping it as is. It has been so long at this point that you are correct that it would negatively affect people who have the site saved.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
Homestead websites always have a site name (**.homestead.com), but once you attach a domain to the site, it would take the place of that site name. If you never purchase a domain name, you will always use the site name that originally came with the site.
Photo of Terry9448

Terry9448

  • 90 Points 75 badge 2x thumb
OK, I suspect a domain name was never obtained. I stumbled on your message looking for SSL information.  It appears the site is not SSL, but we are not conducting business via the site.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
Ah, yes that is one downfall of just using the site name. The site is secure, and if people type https:// before your site name, it will work, but it will not automatically redirect to the secure URL
Photo of Hubert6484

Hubert6484

  • 160 Points 100 badge 2x thumb
My domain name is www.availrecords.com, which I've been with Homestead for years.  I recently attempted to update a published version of my site, but the content did not update. But when I go to www.availrecords.homestead.com, the updates are published there.  I have never had this happen before.  My domain name, excluding ".homestead.com", has always updated without issue.  Please assist. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
I'm not sure if you saw my previous response, but I did assist you and your website is working on my end. You had the domain pointed to itself, which was causing it to not work. I've pointed the domain to your site and it is working now.
Photo of Hubert6484

Hubert6484

  • 160 Points 100 badge 2x thumb
Ok, while using Homestead Sitebuilder, I attempted to publish new content and opted to have 'view page after publishing' which showed my domain.homestead.com.  Why am I still receiving this instead of my domain only for the updated content?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 44,682 Points 20k badge 2x thumb
The preview has always, and is always going to show the site name. However, your domain works and that is what people will visit to pull up your site.

This conversation is no longer open for comments or replies.