Why are my changes not publishing?

  • 7
  • 26
  • Question
  • Updated 2 months ago
  • Answered
  • (Edited)
If you've made changes in SiteBuilder and they don't seem to be
publishing there can be several reasons, and things too look for.


The most common thing is that you are looking at a cached version of the site. On the published site, hit the f5 key on your keyboard to refresh the page. This will tell the browser to download the page again and usually will resolve the issue. If not, then look at the instructions below. 

Access the File Manager by clicking on your domain name at the top of the SiteBuilder page.





Next, click View File Manager





The far right hand column will display the published status.





If any of your pages are not published, you can click on the name of
that file and click the publish button on the top menu and publish the
individual files one at a time.


If all of your pages show a green check mark and "OK" status, then you
will need to check for broken links, or clear your cookies and cash.


How to identify broken links or site error 404 message:

https://community.homestead.com/homes...


How to clear your cookies and cache:

https://community.homestead.com/homes...


If none of these ideas resolves the issue, please reply below with the site, page, and changes made so we can take a look.
Photo of Homestead FAQ

Homestead FAQ, Employee

  • 42,026 Points 20k badge 2x thumb

Posted 3 years ago

  • 7
  • 26
Photo of Brian9133

Brian9133

  • 142 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Website won't publish.

I am hitting the publish button. It goes through the process but doesn't update the site?
Photo of Jessica4440

Jessica4440

  • 102 Points 100 badge 2x thumb
This is happening to me, too. 
Photo of Barrie1596

Barrie1596

  • 854 Points 500 badge 2x thumb
This happened to me with Internet Explorer 11, and Chrome, but it works okay with Firefox.
Photo of Drew N

Drew N, Community Manager

  • 260,178 Points 100k badge 2x thumb
Barrie1596, Some people do have trouble publishing with IE 11, but usually Chrome and Firefox are reliable. I am not exactly sure if the problem is you can't publish except with Firefox, or you see the old site with Chrome and IE 11 after publishing.