When I visit my site, it says "website Warning: Potential Security Risk Ahead." How can I fix this?

  • 0
  • 1
  • Question
  • Updated 6 months ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 7 days of inactivity

When I visit my site, it says "website Warning: Potential Security Risk Ahead." How can I fix this? The SSL was apparently set-up, but I still get the same message.
Photo of Jamie1936

Jamie1936

  • 382 Points 250 badge 2x thumb
  • Extremely frustrated

Posted 6 months ago

  • 0
  • 1
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
Hello,

What website are you seeing this warning with? 
Photo of Jamie1936

Jamie1936

  • 382 Points 250 badge 2x thumb
drjamiekirkpatrick.com
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
Thank you. I have got the SSL initiated for that site. It will no longer display that warning, please allow a little bit of time for this change to propagate.
(Edited)
Photo of Anne4852

Anne4852

  • 190 Points 100 badge 2x thumb
my website has the same warning .. can you or someone have a look at it please? Labraharvest Labradors
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
Hello Anne,

In order to secure the website, you will need to have a domain name attached to the site. You are currently only using a site URL and we do not have the option to apply a ssl this site URL. If you decide to register a domain, you can add a SSL with the information here. https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https
Photo of Jamie1936

Jamie1936

  • 382 Points 250 badge 2x thumb
Thank you so much. It works again!
Photo of Dan6011

Dan6011

  • 190 Points 100 badge 2x thumb
Would you be kind enough to look at wordgrove.com. The same issue applies. This site is registered with CloudFlare. Also why am I now having to insert 'homestead.' into this site address? I've just added a new site (go-archipelago.com) and find that you have inserted 'homesteadcloud.' into my site address. This is unwarranted and complicates things for anyone wishing to access my domain. It looks unprofessional.
(Edited)
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
Hello Dan,

The domain wordgrove.com does show the name servers are pointed to cloudflare, however, it is not showing secured. Review this article and make sure all the final steps from 10 on are completed to turn on the ssl. https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https 

You do not need to use the .homestead and .homesteadcloud extensions to pull up the sites, these are site urls and once a domain is attached you will only use the domain. If you just use the domain http://www.wordgrove.com/ the site will appear. For go-archipelago.com that domain has not been connected to the site and does require the extension. Connect the domain by changing the site association under the domains tab and this will allow you to use the domain go-archipelago.com to pull up the site. 
Photo of Dan6011

Dan6011

  • 190 Points 100 badge 2x thumb
My wordgrove.com account is active and reachable at https://wordgrove.com, but when I use  a .jpg link in my weekly newsletter, I now have to add .homestead in the address for it connect. This is new within the last few weeks. Why is this?
 
Also, I have changed site association for https://go-archipelago.com from https://go-archipelago.homesteadcloud.com under your Domain section as instructed, but nothing has changed. My https://go-archipelgo.com refuses access stating there are too many redirects. I am an illiterate in regard to tech terms (my fault, and to my deep regret), but I have tried to follow directions. What am I not doing right?
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
I do not see why using the direct link to the site https://www.wordgrove.com/ would not work. It is an active link as you can see by clicking it right here. Are you adding this link to a .jpg file on your Homestead site? If so what page and image? I can take a better look. 

For go-archipelago.com I did see it was redirected to itself causing the too many redirects error. I have got that resolved and connected to the correct site go-archipelago.homesteadcloud.com. Please allow a little bit of time for this to site to show but its all connected properly. 
Photo of Dan6011

Dan6011

  • 190 Points 100 badge 2x thumb
This is where my ignorance steps in to make problems where none existed before. I have been using a straight: https://wordgrove.com/TalentLight.jpg, in the past with no problem. These past few weeks have required: https://wordgrove.homestead.com/TalentLight.jpg for the link to work. I notice that you used: https://www.wordgrove.com/TalentLight.jpg in your example.

I am now officially puzzled. All three links work here, and in wordpress.com where I host my newsletter. This has not been true for the last few weeks. The issue seems to have appeared and evaporated of its own accord. Perhaps this connects to my go-archipelago.com issue that you just resolved, for which I am thankful. Color me mystified and impressed. With a grateful bow, I return you to your regularly scheduled programming.
Photo of Michelle C

Michelle C, Employee

  • 35,652 Points 20k badge 2x thumb
Well that is very odd. However, I am glad we got this all worked out for you and I do see all links working. If you do have any other questions we are always here to assist. Thank you, have a great evening. 

This conversation is no longer open for comments or replies.