What are the proper SMTP settings?

  • 0
  • 1
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

I moved my site to SiteGround so I could use WordPress.  It incorporates forms to submit emails.  I would like to continue to use Homestead (RoundCube) to handle emailing - but the emails from the new site are not getting routed to the Homestead SMTP server.

What are the appropriate SMTP settings for Homestead's servers?

The following are the results from the email test (provided by WP Mail SMTP):

WordPress: 4.9.1
WordPress MS: No
PHP: 7.0.27
WP Mail SMTP: 1.2.2
Mailer: smtp
Constants: No
ErrorInfo: SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
Host: smtp.homestead.com
Port: 587
SMTPSecure: string(0) ""
SMTPAutoTLS: bool(false)
SMTPAuth: bool(true)
OpenSSL: Yes
SMTP Debug:
2018-01-12 17:13:06 Connection: opening to smtp.homestead.com:587, timeout=300, options=array (
2018-01-12 17:13:22 Connection: Failed to connect to server. Error number 2. "Error notice: stream_socket_client(): unable to connect to smtp.homestead.com:587 (Connection timed out)
2018-01-12 17:13:22 SMTP ERROR: Failed to connect to server: Connection timed out (110)
2018-01-12 17:13:22 SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting
Photo of Richard6957


  • 70 Points

Posted 2 years ago

  • 0
  • 1
Photo of Drew N

Drew N, Alum

  • 262,826 Points 100k badge 2x thumb
When you transferred the domain and updated your nameservers, that affects your email too. The Internet is directed to Siteground for your email service now. It does not recognize Homestead as the email provider for your domain. If you want to use Homestead mail, you will need to remove the existing mail records from the domain and add our records. Our records can be found in this topic

This conversation is no longer open for comments or replies.