URL redirect is giving a "ERR_CONNECTION_REFUSED" when navigating to old URL with "https"

  • 0
  • 1
  • Question
  • Updated 1 month ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 7 days of inactivity

I have a sub domain setup to redirect my old URL (eastcoastgateoperatorsinc.com) to a new URL (ecgateops.com) and it partially works.

When I try to access "http*s*://eastcoastgateoperatorsinc.com" I am receiving a broken page with "ERR_CONNECTION_REFUSED". However, when I try use "http*s*://eastcoastgateoperatorsinc.com" it forwards correctly. FYI- https://ecgateops.com works correctly.

I am keeping the email running through homestead so I am limited on the changes I can make to DNS.

Any ideas on how to resolve this?
Photo of Shawn4195

Shawn4195

  • 140 Points 100 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Michelle C

Michelle C, Employee

  • 14,428 Points 10k badge 2x thumb
Hello,

The reason you are receiving an error is because there is no SSL applied to eastcoastgateoperatorsinc.com. Candidly speaking, it is not 100% necessary to have a SSL on this domain as no one is essentially interacting with eastcoastgateoperatorsinc.com, it is forwarding to ecgateops.com which does have a SSL. As long as your customer types in just your domain eastcoastgateoperatorsinc.com the redirect will override and show secured, rarely will anyone manually type in a full url https://.... However, if you feel this is necessary you can set up your domain with cloudflare to apply a ssl to eastcoastgateoperatorsinc.com and set up a page rule to apply a redirect https://support.cloudflare.com/hc/en-us/articles/200172286-Configuring-URL-forwarding-or-redirects-with-Cloudflare-Page-Rules
Photo of Shawn4195

Shawn4195

  • 140 Points 100 badge 2x thumb
Thank you for the reply. The SSL was working before the redirect while the site was built on and hosted by Homestead. Is there a trick I can use to gain that back without setting up a new Cloudflare account. There is a also an issue with Google directing search results for the company using https and it is causing the same errors.

Was the previous SSL included with the Homestead website builder which is why I do not have one now attached to the url?
Photo of Michelle C

Michelle C, Employee

  • 14,428 Points 10k badge 2x thumb
Since the domain is attached to a Sitebuilder plus site, which it needs to be to apply a url redirect, Homestead does not have a way to apply a SSL other than using Cloudflare. Yes, it seems you may have previously had it attached to WebsiteBuilder which does have the SSL.

To fix the search result you will need to request a recrawl from a google webmaster tools account to get those links updated. 

This conversation is no longer open for comments or replies.