Tabbing through a created form

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archiving inactive content

I created a patient intake form for our website using SiteBuilder Plus, but when I press tab while in a text box or option button, it doesn't always go to the very next item. It might skip one or go to another line and then go back to the one afterwards. It just seems random. I thought it might have something to do with 'bring forward/send backward'. But I went through and clicked 'bring forward' on every single text box in the order I would want them to tab and it did nothing.
Help!
I don't have the page live yet, so I hope you can answer the question without actually seeing the page.
Thanks!
Photo of Mike8385

Mike8385

  • 170 Points 100 badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 48,072 Points 20k badge 2x thumb
Hello,

This has to do with the order that the custom form elements were added. Bringing elements forward or backward would not affect this. If you want your page visitors to be able to tab through the form in order, you would need to go through your form, then delete and re-add the elements in order. Our builder cannot tell the order in which you want the form to be, so it can only go off of the order that the elements were added.
Photo of David0589

David0589

  • 634 Points 500 badge 2x thumb
I often deal with this - here is my work around on a new form.
I create a blank page - then open the form i created.
Copy all the elements on the form, paste (clone) into blank page, 
then delete all items on the page I am keeping - 
then go back and forth copy and pasting one element at a time to make sure they fall in place with the tab feature.
it might take you a couple times - but now all my forms work correctly, and print correctly.
Photo of Mike8385

Mike8385

  • 170 Points 100 badge 2x thumb
Thank you. I had about 40-50 elements that I needed to delete and redo. It was tedious, but not too bad. Now it's working wonderfully. Wish you could just reassign the order by delineating in some manner in each item's settings. But alas, now I know. Thanks again!

This conversation is no longer open for comments or replies.