Strange message appears when loading website

  • 0
  • 1
  • Problem
  • Updated 3 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 7 days of inactivity

When I load my website http://intimatehair.com on my computer it loads perfectly. If I include the URL in an email, a window appears with a partial message. And I was told by an Affiliate Company "The site listed in your account doesn't load any website when I follow it."  I've attached a screenshot of the portion of the message that appears.  Any ideas?

Photo of Bob1065

Bob1065

  • 990 Points 500 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of steve4468

steve4468

  • 3,594 Points 3k badge 2x thumb
Is it possible that the affiliate's link has https in the address and not http as your site does? I've seen similar problems in other threads on this forum. If it is an https vs. http problem you could contact the affiliate to have them change the address link or use simply use cloudflare to secure your site.

Good luck
(Edited)
Photo of steve4468

steve4468

  • 3,594 Points 3k badge 2x thumb
Cloudflare is free and there are easy to follow and precise directions on this forum to set cloudflare up. Just do a simple search.
(Edited)
Photo of steve4468

steve4468

  • 3,594 Points 3k badge 2x thumb
Thus the reason for the strange message.

There's quite a few sites out there that when you enter a domain name for an associated link you're only presented with a "www" and then a box to enter the domain name. They don't give an option to enter the full url and https is automatically added. Because of this if the site isn't secured the link probably won't work and you get what's described above by the poster.
(Edited)
Photo of Michelle C

Michelle C, Employee

  • 25,370 Points 20k badge 2x thumb
Thanks for sharing this. 
Photo of Bob1065

Bob1065

  • 990 Points 500 badge 2x thumb
Thank you all for the comments. How do I get the site 'secured' or put "SSL" in place? I will send the affiliate all of the comments and hope for the best. But never had this issue before.
Photo of Bob1065

Bob1065

  • 990 Points 500 badge 2x thumb
The https link does not seem to work. Only the http link. Huh.
Photo of steve4468

steve4468

  • 3,594 Points 3k badge 2x thumb
Most likely it's because your site isn't secured with https.

If you follow this link you should be able to secure your site with https. Just know that if you're using the desktop version of sitebuilder the https may only last a day or so...if that. So if you're using desktop SB you should really use sitebuilder plus to re-publish and from now on for all editing if you want the https to be permanent.

https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https

Just be sure to take your time and follow the directions presented EXACTLY. A little mistake can cause all sorts of problems but the directions are complete and fairly simple to follow. Once your site has https applied all affiliate links should work.
Photo of Michelle C

Michelle C, Employee

  • 25,370 Points 20k badge 2x thumb
Hello,

You can specify what image is displayed upon sharing and posting your website link. Here is some information on setting up the image for shares. https://community.homestead.com/homestead/topics/sitebuilder-plus-how-to-specify-the-image-used-by-facebook-for-shares-and-likes However, I am unable to replicate that image and the site does work when sending it as a link, maybe it was a partial link? 

This conversation is no longer open for comments or replies.