Skeleton page load

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

Can we get an update on where things stand with correcting the issue of pages loading as the example below?  I would like to start promoting our new site but I am hesitant to start the effort when the first impression of our site looks like this.

Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb

Posted 1 year ago

  • 0
  • 1
Photo of Todd H

Todd H, Social Media Specialist

  • 18,536 Points 10k badge 2x thumb
Development is definitely aware of the loading behavior. We will provide updates as we get them.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Is it possible the highlighted wait message, "Waiting for analytics.seogears.com" has anything to do with the skeleton load issue?  I just happened to notice it in the footer of the browser.

(Edited)
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
It is contributing, but not the cause. The cause appears to be just page load speed. The more that is loading the more pronounced the skeleton page is. I have alerted the developers and the network folks to this to see if they are able to make adjustments.

You can remove the code, but it may still have the issue. I have seen it on other sites that do not have the SEO code. You would also not be able to track the SEO when removed.

I am sorry this is taking a while, but I am still working on it. (All of it)    :)
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Drew, thanks for the response.  Unfortunately, removing the tracking code isn't an option. I've noticed it on all pages, even the pages that are lighter loads. The home page seems to be the most prominent but that probably because that's the one I hit most often. I just happened to notice the SEO Gears message so thought I would pass it on in the outside chance it would help. Thanks again
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
More information is always good, and I agree that removing the code is not an option which is why I mentioned that. I am hoping I will hear back from the network folks that they can make some adjustments. The builder isn't the only new thing. All the new builder sites are housed on new servers, so there still may be some tweaking to do for optimal performance.
Photo of Andrew6573

Andrew6573

  • 390 Points 250 badge 2x thumb
The seogears code doesn't have anything to do with it. All the new sites are loading this way.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
One thing that is odd....It never happens when I am using a Safari browser on my Mac but it occurs on every other browser on either Mac or PC and I've never seen it happen on a mobile device like an iPad or phone.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Can someone at Homestead please provide an update on when a solution to this problem will be available?  It's been more than two months since it was first reported. If it cannot be fixed please let me know.
Photo of susan2829

susan2829, Champion

  • 42,858 Points 20k badge 2x thumb
lmao  Wait til tomorrow and maybe Drew or Todd can sort it out. It's the only difference that stood out between your <head> info and mine.
Might be nothing, might be something, but I like the secret sauce concept. :)
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Sounds like a plan...thanks for taking a look.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
I am not sure if this provides a clue but....
Photo of susan2829

susan2829, Champion

  • 42,858 Points 20k badge 2x thumb
I keep telling you that Gears is bad ju-ju. lol  Actually it's Greek to me, but the guys might know.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
This may be helpful to the Homestead Team.  This morning I opened our site using FireFox as a test.  As usual, the page opened in the skeleton format and then presented this error.
Photo of Andrew6573

Andrew6573

  • 390 Points 250 badge 2x thumb
I started building a new site two days ago and tested it out. It still loads this way.
Photo of Brian4612

Brian4612, Champion

  • 32,244 Points 20k badge 2x thumb
Please add my concerns as well Drew, I have almost completed my replacement "websitebuilder website" but loath to redirect my domain name to it as it continually "Skeleton" loads. I appreciate your doing your best for us Drew but in my case retirement is looming and I need a professional looking, properly responsive website.
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
Which site name do you see this on Brian? I will add it.
Photo of Brian4612

Brian4612, Champion

  • 32,244 Points 20k badge 2x thumb
Much appreciated Drew

http://hssurveys.homesteadcloud.com/  and screenshot of what comes up with direct access with url
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
Got it. Does it do that every time. On my computer it does not do it at all in Chrome, and I had to hit refresh in Firefox a couple of times to see it.
Photo of Brian4612

Brian4612, Champion

  • 32,244 Points 20k badge 2x thumb
Used Firefox for years but will try chrome see what happens.
Photo of susan2829

susan2829, Champion

  • 42,858 Points 20k badge 2x thumb
Doesn't do it in Chrome, but does in Fire Fox...don't know about Safari.
David's does it in both.
Mine does it only in FF.
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
I see this on yours too. Hopefully this will help.
Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
This post was accidentally archived. As it is an ongoing issue, we have reopened it. Another topic was created and there are a few more comments there. You can read any of those comments in the link below.https://community.homestead.com/homes...
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Drew can you tell us if there is any new information on the skeleton issue?  Has the cause been identified and is there a timeline to resolution you can share with WebsiteBuilder users?
Photo of susan2829

susan2829, Champion

  • 42,858 Points 20k badge 2x thumb
Laffin accent? really? too funny.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Well heck yeah....the only ones I know that says "reckon" is Matt Dillon and Festus from Gunsmoke on TV...then again you're probably too young to remember Gunsmoke...of course, I only know it from the reruns....
Photo of susan2829

susan2829, Champion

  • 42,858 Points 20k badge 2x thumb
I actually picked up "reckon" from watching too many Brit shows. I liked it better than "think" and started using it and now it just comes out. And um, I remember Gunsmoke from the original days.

Photo of Drew N

Drew N, Community Manager

  • 251,604 Points 100k badge 2x thumb
I am trying to contact them for an update. The code is strictly tracking code. It has nothing to do with the SEO itself other than reporting. If you leave it out though, you probably want to tell them what you have done. They will stop receiving info concerning traffic.
Photo of david2953

david2953

  • 6,370 Points 5k badge 2x thumb
Drew, Thanks...I spoke with SEO Gears this morning and they said the same.  I use Analytics for reporting purposes so the only thing I will lose is the reporting provided by SEO Gears. Removal will have no effect on page ranking.  

For those of you that are experiencing the same problem, it's my understanding that removing the SEO Gears code is not a long term solution and that this issue is still being worked by Homestead.

This conversation is no longer open for comments or replies.