Secure page links to non-secure pages

  • 0
  • 1
  • Problem
  • Updated 1 month ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 7 days of inactivity

Some time ago, I followed your instructions for securing my website (https).  That has been completed now.  I have two remaining problems, though.  First, if someone just enters my domain's name (not including http or https) into the URL field of their browser (e.g. trich-free.com), what loads is not the secure version of the site, but the non-secured version.  Can you tell me how to fix this?  Second, there is one page I have specified in an email to my subscriber list.  That link specifically includes https://.  When I test the link, it works - the browser does indeed show the page that loads to be "Secure" - but when I use your system to specify a link from that page to another page in the same domain, the page that loads is the NON-secure version of the page (the URL field says "Non-secure").  Can you tell me how to fix this as well? 
Photo of Robert0753

Robert0753

  • 262 Points 250 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Michelle C

Michelle C, Employee

  • 36,102 Points 20k badge 2x thumb
Hello,

This domain does route through Cloudflare for the SSL but there may be a setting that may be missing. Verify steps 12 and 13 are enabled to show secured. https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https

https://community.homestead.com/homestead/topics/cloudflare-common-cloudflare-issues

This conversation is no longer open for comments or replies.