Poor stats for a week since using Cloudflare to secure it

  • 0
  • 2
  • Problem
  • Updated 5 days ago
  • Acknowledged
The stats for my site www.knitalteration.com have not been reporting properly for a week since using cloudflare to make it a secure site. The site is available online and an occasional hit or bot is recorded. But it does not record any of my customers who i know have just visited the site or my own visits to the site in a regular fashion. Please have someone at Homestead look into this. I use the stats to view how my customers are using the site. They are important to me.
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb

Posted 4 weeks ago

  • 0
  • 2
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
Hello Sandy3192

It is possible that it is still updating, but at this point, I will put a ticket in to see if they can find anything else causing this. There isn't an ETA I can give with that. One option that remains to get the stats working quicker would be to use Google Analytics. I know I had mentioned that before and it wasn't your first option, but it is an option.
Photo of Marcella7180

Marcella7180

  • 464 Points 250 badge 2x thumb
Pls help. My website shows not secure. What i need to do?



Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Marcella,  I had this problem, too. I had everything in place i.e. NameServers etc. but still not secure. I called HomeStead customer service and a very nice fellow 'walked' me through some tabs that needed to be 'turned on' at Cloudflare. I suggest calling them.
Photo of Marcella7180

Marcella7180

  • 464 Points 250 badge 2x thumb
thanks
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb

Thank you for having someone look into this Elyzabeth. It is appreciated.
Photo of Mark0743

Mark0743

  • 136 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Site Stats not working after Cloudflare update.

The stats for my site www.clfcostarica.com (www.kuzdas.com) have not been reporting properly for about 2 weeks since using cloudflare to make it a secure site. The site is available online and an occasional hit or bot is recorded but it does not record any of my visitors who I know have just visited the site or my own visits to the site. Please have someone at Homestead look into this. Thank you!
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
Hello Mark0743

As you may have seen on this post, I have created a ticket for this issue. So far it has only been reported by you and Sandy, who originally posted this question. As I told her, there isn't an ETA I can give with that. One option that remains to get the stats working quicker would be to use Google Analytics
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Hi Elyzabeth and Mark I am still waiting for the stats to show up. It's been over 2 weeks. Elyzabeth, are you saying that using Google Analytics will help the Homestead stats show up? I thought you were saying to use Google Analytics in place of Homestead stats. As I mentioned before, Google emails me several times a week because I use their Ads. They feel like Big Brother and I like using less of their services, rather than more. They are like a necessary if useful nuisance (or worse) as it is. 

Thanks for speaking up Mark! You both are appreciated for the feed back.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
Hey Sandy. I am not saying that Google Analytics will fix our stats, but if you need a faster solution to be able to view site stats, I would recommend using Google Analytics instead. I do understand that is not your preference.
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Elyzabeth it's been over 2 weeks without regular stats! I am feeling ignored. Will I ever have Homestead stats again?
Photo of Mark0743

Mark0743

  • 136 Points 100 badge 2x thumb
Thank you Sandy for following up with Elizabeth. I, also, would like an update on the status of this problem. 
Photo of Judy6647

Judy6647

  • 200 Points 100 badge 2x thumb
I am having the same problem also after securing my site with cloud flare. It completely stopped showing any activity on my site . I too depend a lot on
this feature and need help in resolving it. . 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
It is still ticketed to our dev team, but there is very little information regarding this issue, not very many people have reported this. If you can give as much detail as possible as to what steps you are going through to test this issue, or any information of a time you know someone visited your site and the visit isn't recoded, I can pass that information up to our dev team to put more information on the ticket.

A more immediate fix would be to use Google Analytics. I know that isn't some peoples first choice, but if you absolutely need more immediate stats, this would be your best option. We provide a very basic stats tool, Google Analytics is much more advanced and will work better.
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Hello Elyzabeth,
Thank you for your follow-up. I am able to view my site - https://www.knitalteration.com when I use Internet Explorer and a hit shows up on the HomeStead stats. When I use Goggle Chrome or YaHoo or most other browsers I can view the site but I get no stat hit. I just did each of these a little after noon around 12:21PT today. Google Ads indicates around 25-30 customers hits a week from them that do not appear on the Homestead stats now, but that used to before using CloudFlare.  There are some hits that do squeeze though occasionally like bots (even from Google?) and two regular visitors from Ann Arbor, Michigan and another from Tukwilla, WA. Why only these, and who they are? I have no idea. Perhaps they are using Internet Explorer, too?
The Cloudflare Name Servers are entered at DirectNic  where I originally  purchased my domain name. That all works as far as the' https' display and the site being available on the web. Cloudflare indicate numerous hits daily to the site (way more that Homestead stats ever did), but of course no customer details.
My business is seasonal and it heats up dramatically with the first cold weather and new fall season. Over the summer the site generally gets something like 15-20 hits a day. This time of year that starts to increase significantly.
My customers are rarely local but rather from all over the country/world. My service is unique - 'a dying art ' as some say. Happily, I rarely loose a customer once they find me. So I am glad that the site is available, but I really miss my HomeStead stats that help me stay in tune with the daily flow of business and a new line of related products that I am offering. Any help with this is appreciated.
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Elyzbeth,

I can add to the above information, that Google Ads report 45 Google Ad hits for last week between 9/9 and 9/15. Homestead shows 20 hits for that same period, most of which were various bots, me  or those described in my previous post above. This Google report does not include simple Google hits off the web. These Google hits are for ads I have placed on relevant pages.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
I will pass this information along.
Photo of Eric6098

Eric6098

  • 762 Points 500 badge 2x thumb
I converted our website to https with Cloudflare on 8/14. Since then, the "visits per day" stat from Homestead is only averaging 7. Before 8/14 I averaged about 25. I began panicking, thinking our site is not getting seen. However, when I check Google Analytics, I can see the visits per day did go down a bit, but they are much higher than what Homestead is reporting (thank goodness!).

I think this is something Homestead needs to take a look at.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
I do have a couple question for those of you experiencing these discrepancies.

  1. In the Cloudflare account, under the Crypto tab, do you have "Always Use HTTPS" and "Automatic HTTPS Rewrites" turned on?


  2. When testing your own site, do you go to the HTTPS version or HTTP and let it redirect?
Photo of Sandy3192

Sandy3192

  • 388 Points 250 badge 2x thumb
Hi Elyzabeth,


Yes, I have 'On' for both of those tabs at Cloudflare. 

I am able to log in to my site using both HTTPS and HTTP as well as plain www....

Usually these do not show up as 'hits' on HomeStead stats. Occasionally they will show up when I use Bing as the browser. Other than that I get occasional hits from various bots (including Google bot) and a few random hits from around the country/world.  As I have said before my site is readily available as a secure site and I am grateful for that. I have logged in from various computers and browser and queried my customers about their experience. I look forward to having this cleared up.
Photo of Eric6098

Eric6098

  • 762 Points 500 badge 2x thumb
1. Yes
2. When I go to my site, I don't type either http or https, just the name of my website, advancedceramictech.com

Kelly
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
Ok thank you