not able to edit my website in site builder for several days

  • 0
  • 1
  • Question
  • Updated 6 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I cannot do anything.....it just keeps loading. This has been occuring for many days. I need to update my website!!! Please help!!! I empty my history and cache every day!!!!
Photo of Wendy9564

Wendy9564

  • 236 Points 100 badge 2x thumb
  • frustrated

Posted 6 years ago

  • 0
  • 1
Photo of Wendy9564

Wendy9564

  • 236 Points 100 badge 2x thumb
I can not load pictures, publish my site, move items, etc. I have to keep logging in and closing out. This is craziness!
Photo of john3106

john3106

  • 60 Points
I am having the same problem! I hope they resolve it soon. It takes too long to get
anything done.
Photo of Wendy9564

Wendy9564

  • 236 Points 100 badge 2x thumb
how many days? It has been all week for me!!! :(
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Wendy can you explain exactly what you are experiencing.

We have had not SiteBuilder outages and the server is running normal.

As a first troubleshooting step, try using the Firefox web browser, and let me know what happens.

Mike
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
john3106,

Can you also explain with some detail what you are experiencing. We've had not outages or server problems with the SiteBuilder. It has been running fine.

Mike

This conversation is no longer open for comments or replies.