my submit button returns to a deadlink

  • 0
  • 1
  • Problem
  • Updated 1 week ago
  • Solved
I inserted a SUBMIT button on my registration page.  This link routes to a dead old link.  how do I fix this to redirect back to my home page or initial page button is on?  Its been a problem for months, just now have time to repair.
 http://www.dukecitydrivereducation.org/Registration.html
Photo of Lisa1020

Lisa1020

  • 202 Points 100 badge 2x thumb
  • frustrated

Posted 2 weeks ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
Hey Lisa1020
If you click on that submit button in the builder, you'll want to choose the option to have is direct to another page after it submits. You can choose the registration page or the index page.
(Edited)
Photo of Lisa1020

Lisa1020

  • 202 Points 100 badge 2x thumb
I dont see the Option to redirect.  This is what I have been looking for.  I clicked INSERT/Submit. the right of the screen doesn't show Redirect to enter link???
Photo of Lisa1020

Lisa1020

  • 202 Points 100 badge 2x thumb
it redirects to an old name, http://www.drivetechnm.org/Registration.html" how do I rename this to DukeCity??? http://www.dukecitydrivereducation.org/
Photo of Lisa1020

Lisa1020

  • 202 Points 100 badge 2x thumb
I need to "Text/Redirect" to show this page as received for my students that register through this link.  I cannot seem to do both??
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
Both domains are connected to the site, but drivetechnm.org is the "main" one since it is older.

You can create a thank you page to redirect to, and have a navigation menu so they can go to another page if they need to. Right now, the text option is not working because our system tries to redirect to a secure site automatically.
Just click on the submit button you have and choose the Page option under "Thank you Page" If you create a thank you page, you can redirect to that from here.
(Edited)
Photo of Stepheon7231

Stepheon7231

  • 140 Points 100 badge 2x thumb
I am also added a submit button on one of my contact forms.  I have it linked to the email, but when the submit button is clicked, it brings up the messenger icon.  I do not want this.  Previously, you could have this submit button clicked and the info would go directly to the email linked to the page.  Now it does not do that.  Is there anyway to have this button clicked and the information goes to the email linked to the email?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
Hello Stepheon7231

What site are you experiencing this issue on?