Media files

  • 0
  • 1
  • Question
  • Updated 5 years ago
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

2 situations. 1. Why when uploading a media file to a page, dies the viewer of the web page have to download (Download the Windows Media Player Firefox Plugin) if Windows media player already exist on their computer? This absolutely kills the intention
2. Why when uploading a sound file does the file now play automatically without it being able to be control by the viewer as before?
Photo of Ruben8365

Ruben8365

  • 212 Points 100 badge 2x thumb

Posted 5 years ago

  • 0
  • 1
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The Windows Media play installed on the PC is a slightly different program than the web browser plugin. So, if your browser does not already have a media player installed, you'll have to install one.

If you are experiencing a situation where all the media files play automatically then I'm guessing you are using the Chrome browser. For some reason Chrome ignores the code for the "click to play" controls and just plays everything automatically.

About the only way around this is to create standard hyperlinks to the media files rather than using the media player in SiteBuilder.

Mike
Photo of Ruben8365

Ruben8365

  • 212 Points 100 badge 2x thumb
There is a media player installed in every computer that we tested the ad in media file. When opening site builder and using the preview, they work fine, however in every instance where it is form the site, it goes directly to the download Firefox ad on. Why does it do that?

Thanks in adavance
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Can you tell us which site and page this is occurring on, and we'll be happy to take a look?

Mike
Photo of Ruben8365

Ruben8365

  • 212 Points 100 badge 2x thumb
Yes, it is on a test page. The test page is http://www.mypgw.com/index-audio.html Thanks
Photo of Drew N

Drew N, Alum

  • 262,796 Points 100k badge 2x thumb
It works for me in both IE and Firefox. There is a bit of an issue with Firefox and WMP plug in. I found this on the Firefox website.

Installing the plugin

Go to the plugin download page on Interoperability Bridges.
The Interoperability Bridges page also contains more detailed installation instructions.
Click "Download Now" You will be prompted to save a file.
Save the file to your desktop.
Once it has downloaded, run it, and the plugin will install.
When the installation has finished, close Firefox:

At the top of the Firefox window, click on the Firefox button and then select Exit
When Firefox has completely closed, start Firefox up again.

In the Location bar, type about:config and press Enter.
The about:config "This might void your warranty!" warning page may appear. Click I'll be careful, I promise! to continue to the about:config page.
Search for plugins.load_appdir_plugins
Double-click plugins.load_appdir_plugins to change its value to true.

At the top of the Firefox window, click on the Firefox button and then select Exit
. When you restart Firefox the plugins will be enabled.

Drew
Photo of Ruben8365

Ruben8365

  • 212 Points 100 badge 2x thumb
I see, however I see this a problem in Google chrome. With the amount of people on Google chrome, do you have a fix for that? Thanks
Photo of Drew N

Drew N, Alum

  • 262,796 Points 100k badge 2x thumb
I am sorry, in Chrome it take you to the Firefox add on page?

There is a known issue with Chrome. You have 2 files and neither starts automatically. Chrome updated a while ago to ignore that flag and so anyone currently using Chrome will automatically have all media files play at once. Our developers are working on it, but unfortunately the only real solution for Chrome is to have only 1 media file on a page.

Drew
Photo of KenDell1659

KenDell1659

  • 94 Points 75 badge 2x thumb
I am having this same issue...it is a pain in the ass. .WMV files do not play in chrome, and only directs you to a Firefox plug-in. Please fix this, its annoying.
Photo of Matt B.

Matt B.

  • 1,434 Points 1k badge 2x thumb
Hello KenDell1659,

There wouldn't be anything that could be fixed from our end to get those files to play on your computer. The browser plugin is required for those files to play. So you just need to install that plugin, and then likely restart your browser, and they should play.

Matt

This conversation is no longer open for comments or replies.