Links to another URL will not open the page/ address when clicked on

  • 0
  • 1
  • Question
  • Updated 7 years ago
  • Answered
Archived

This conversation was archived and is no longer visible to community members.

When clicking on linked text which normally opens another window with the linked webpage- I get a white, black page that says "page not found." This cannot be the case as the page I am linking to does in fact exist!

Help!

dan@premiershinedetail.com
Photo of Daniel5463

Daniel5463

  • 94 Points 75 badge 2x thumb

Posted 7 years ago

  • 0
  • 1
Photo of Ehsan Zaheer

Ehsan Zaheer

  • 39,954 Points 20k badge 2x thumb
Hi Daniel5463,

Welcome to the community!

I noticed this happens with the News link, is there another link that this happens with? The news link is associated with a page titled blank (blank.html) which doesn't exist which is why you see that error page.

To fix this, log into Sitebuilder Plus and click on your navigation menu.

Click the Links Tab > News Button > Edit Link

Browse (Existing Page or File) > News

After saving/publishing, all of your links should work.

Hope this helps, thanks!

Ehsan
Photo of Daniel5463

Daniel5463

  • 94 Points 75 badge 2x thumb
Ehsan-
Thank you for your reply- should have clarified a bit as to what my problem is.

If you go to the following page on my site (the portfolio page):

http://www.premiershinedetail.com/Por...

And if you attempt to click on any one of the hyperlinked text it will not link you to the correct web address but instead come up with the "page not found" page.

Thank you for your help!
- Dan
Photo of Ehsan Zaheer

Ehsan Zaheer

  • 39,954 Points 20k badge 2x thumb
Hi Dan,

Thanks for clarifying. If you look at the url when you click on one of the hyperlinks, it looks like it's missing the l at the very end (htm instead of html).

I added an l and it loaded the page just fine for me, so, I think you'll just need to add an l to the end of the urls for those hyper links (or re-copy/paste the urls again).

Let me know if that fixes that issue or not, thanks!

Ehsan
Photo of Daniel5463

Daniel5463

  • 94 Points 75 badge 2x thumb
Looks like it solved the problem! You the man!

THANK YOU!

- Dan
Photo of Ehsan Zaheer

Ehsan Zaheer

  • 39,954 Points 20k badge 2x thumb
Hi Daniel5463,

You're welcome, glad I could help!

Ehsan