links to other pages don't work

  • 1
  • 1
  • Question
  • Updated 4 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

I can go to other pages on my home page but while on those other pages the navigation links don't work
Photo of Theresa7020

Theresa7020

  • 232 Points 100 badge 2x thumb
  • unhappy

Posted 4 years ago

  • 1
  • 1
Photo of James7380

James7380

  • 1,002 Points 1k badge 2x thumb
I have found when adding a link you first have to remove a link prior to adding a new link. I hope this helps.
Photo of Brian4612

Brian4612, Champion

  • 32,264 Points 20k badge 2x thumb
As James mentioned, If you use a preset navigation then adding a link to say "home" it will work on all the pages... However, you may have lost the links so check the navigationin edit mode on every page to see if the link has gone and if so replace it
Photo of themieleman

themieleman, Champion

  • 69,672 Points 50k badge 2x thumb
Are you using the site navigation menu on all pages? Have you created other menus. Review your menu links.
Photo of Theresa7020

Theresa7020

  • 232 Points 100 badge 2x thumb
Nothing seems to be working that I try. Navigation works on contact and home page but not the other pages. This is my site: thealternativekitchen.com
Photo of Theresa7020

Theresa7020

  • 232 Points 100 badge 2x thumb
but it doesn't link back to home on contact page...
Photo of themieleman

themieleman, Champion

  • 69,672 Points 50k badge 2x thumb
Theresa: Gotcha. It acts like you may have an overlay that covering your menu. If you right click your mouse, you can layer elements, move to front or move to back. Try using this feature on each page, Select the menu > right click > send to back. This will produce access to your menu elements. Let me know how this works for you.
Photo of Theresa7020

Theresa7020

  • 232 Points 100 badge 2x thumb
Yay! You're awesome! There was something overlaying, but not thinking there would be a problem, I never messed with it. It was my top line, title & tagline. The edit box was longer than needed so raised it up over the navigation bar on all pages and it works. I also did the "bring forward" thing too. Thank you so much!!! :)
Photo of Theresa7020

Theresa7020

  • 232 Points 100 badge 2x thumb
I went and sized all my text boxes on all my pages too.
Photo of themieleman

themieleman, Champion

  • 69,672 Points 50k badge 2x thumb
Good job!
Photo of Brian4612

Brian4612, Champion

  • 32,264 Points 20k badge 2x thumb
All links working fine.. good call mieleman
Photo of Drew N

Drew N, Alum

  • 262,826 Points 100k badge 2x thumb
I'm glad themieleman was able to help you out.

This conversation is no longer open for comments or replies.