Image Alt Tags Appear with Hover Over?

  • 1
  • 1
  • Question
  • Updated 1 month ago
  • Acknowledged
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archiving inactive content

I have been diligently adding Alt Tags and pop-up animation to all my images and I had thought the Alt Tag descriptions were supposed to be able to be read with "hover-over" but when I preview, this doesn't happen.  How do I make them visible?  This is useful to browsing clients and absolutely necessary for users using a reader.  I thought we were more more or less required to be reader friendly?  Please advise.
Thanks! 
Photo of Susan

Susan

  • 2,350 Points 2k badge 2x thumb

Posted 1 month ago

  • 1
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 17,578 Points 10k badge 2x thumb
For now, we do not have that ability.  The alt text does work for SEO purposes, but unfortunately  you would have to add the image via code to get the functionality you want. We cannot give you the code for that, but I do want to warn that it would take a lot of time to get the URL for all of your images.
Photo of Susan

Susan

  • 2,350 Points 2k badge 2x thumb
Ok... seems odd to me tho, it was available in SiteBuilder, wasn't it?  Are the search engines able to "read" the alt codes to assist in client searches? What is alt text there for?
Thanks,
Susan
Photo of Aki5540

Aki5540

  • 2,082 Points 2k badge 2x thumb
We found this out 8 months ago. For us it was devastating because we rely on image searches for our handmade stuff. We had to create another website with another company to get some of our images back up on the internet. We are using the site here as a catalogue. I think we can recover in a year or so. If it wasn't so much work we would sue. Drew said they had no idea this was a "problem" but they'll get right on it, highest priority. We waited patiently. That was 8 months ago. Elyzabeth has told me it's taking a lot of time because it's a lot of work. So alt, titles and descriptions are not read by search engines.
Photo of Susan

Susan

  • 2,350 Points 2k badge 2x thumb
Thanks Aki... this is also not good news for our business.  I have been on the whole very happy with Homestead but I can't help but be disappointed by this new obstacle.  It seems to me that several important things may have been glossed over in the new WebsiteBuilder not the least of which is the missing spell-check which should have been a given.  I have found work-arounds for spell-check but I guess the only way to get around alt-tags uselessness is to manually do captions with text boxes over each image.  I move the images around every so often and this makes it problematic.
...I wonder if anyone has come up with a "work-around".
Elyzabeth... why is there a place for alt-tags if they serve no purpose?  Or am I misunderstanding something?  Please, please explain.
Photo of Susan

Susan

  • 2,350 Points 2k badge 2x thumb
Wait a minute... I just re-read Aki5540's comment above.  Page titles and descriptions are not being read by search engines?  Please tell me I am misunderstanding.  Elyzabeth, I am blown away if this is so.  Please, please explain this carefully so that I can be sure I understand?
Thanks!
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 17,578 Points 10k badge 2x thumb
No, it has nothing to do with page titles and descriptions. It is Image title tags. As I told Aki before, the images do have image alt tags, just not title tags.
The pop up text you mentioned, Susan, is not the alt tag. It is a title tag that makes that display and that is what Website Builder currently does not have the functionality to create.
Sitebuilder use to create both alt tag and title tag when alt text was entered. We have a ticket to work on this functionality in Website Builder, but it is not a small fix, so it is taking time to do.
Photo of Susan

Susan

  • 2,350 Points 2k badge 2x thumb
Thanks Elizabeth!  I also found out that I could get the function I want if I use Image Gallery instead of individual images, as I had been doing. Is that correct?  Luckily I had saved images to do last while rebuilding our site and I hadn't added too many yet.  I am going back and adapting to the "pre-set" galleries and I am once again a reasonably happy camper.  Now, I will be a delighted camper once we get spell-check!  
Thanks again, and sorry I panicked!
Photo of Aki5540

Aki5540

  • 2,082 Points 2k badge 2x thumb
Alt, titles and descriptions for the image galleries are not read by search engines. That was the problem I was referring to.
The problem as I understand it is the way the images have been stored prevents google from indexing them.

From Drew, "The problem is the way Google hosted services is storing the images. It looks like a CDN but is not. It is preventing the proper indexing. We are working to resolve this. I will let you know anything as I get information".

I've copied the private conversation for the past 8 months.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 17,578 Points 10k badge 2x thumb
Correct, but what Susan was referring to (because this is her post and her question) was not indexing. She was referring to the "hover over" option. And she called and got her answer.

We have already addressed everything we can with your concern. I am truly sorry that it has affected you as much as it has, and if there was anything Drew or I could personally do to speed it up, we would. However, that is not the case. We are at the mercy of when our development team is able to launch this large-scale change to the way our builder holds images. They will provide the fix you need as soon as it is possible for them to do so.

This conversation is no longer open for comments or replies.