I now have the information Homestead requested for resolving e-mail problem

  • 0
  • 1
  • Problem
  • Updated 3 weeks ago
  • Acknowledged
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archiving inactive conversation.

About 3 weeks ago, I posted about a problem I started having getting e-mails after I got the https certificate from Cloudflare. I received a prompt response from Elyzabeth, asking for some additional information, which it took me till now to get. The original conversation has been closed for additional responses, so I'm opening this new conversation. I was unable to add screenshots, so I've cut and paste the information below. Thanks for your help!

Hi there,

Thanks for contacting Cloudflare Support and apologize for the issues you're facing here.

I have checked DNS part settings of your domain. Since Cloudflare does not proxy on port 25 (SMTP) - email service protocol by default for free customers, Cloudflare only takes its part as DNS resolver. As I check, the MX records are resolved correctly:

   dig MX ctcparty.com +short
   1 imap.homestead.com.
   1 emailmg.homestead.com.
   2 emailmg.homestead.com.

I went ahead to find the A records of emailmg.homestead.com and imap.homestead.com. which is the email services handled by Homestead:

   dig emailmg.homestead.com. +short
   66.96.135.48

   dig imap.homestead.com. +short
   66.96.135.96

However, when I performed a basic test of SMTP capability of those IP addesses:

   nc -v 66.96.135.96 25
   found 0 associations
   found 1 connections:
      1: flags=82<CONNECTED,PREFERRED>
      outif en0
      src 10.120.159.176 port 54765
      dst 66.96.135.96 port 25
      rank info not available
      TCP aux info available

   Connection to 66.96.135.96 port 25 [tcp/smtp] succeeded!
   220 ESMTP Fri, 21 Sep 2018 04:04:28 -0400: UCE strictly prohibited
   421 bosauthsmtp15.yourhostingaccount.com: SMTP command timeout - closing connection

   nc -v 66.96.135.48 25
   nc: connectx to 66.96.135.48 port 25 (tcp) failed: Connection refused

Both of them refused connection. You may need to provide the testing results above to Homestead and ask them to check why the 25 port is not accessible for 66.96.135.48 and why 66.96.135.96 is not sending the expected response.

Hope this works for you. Please kindly let us know if you have more questions and I will be happy to assist. Thank you for using Cloudflare!

Best Regards,
Shanshan 

Technical Support Engineer

Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb

Posted 3 weeks ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,310 Points 10k badge 2x thumb
Hello Bennett3683

Unfortunately, that is not the information I need. I simply need to you log in to your Cloudflare account, go under the DNS tab and take a picture of all the records. Cloudflare cannot troubleshoot this because they know nothing about Homestead's system, so what they are trying to look into in that message above means nothing and has nothing to do with Homestead.

Once you have that picture, please post it here.
Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb
Thanks very much, Elyzabeth. Shown below is the report available under the DNS tab. (Because of the report's length I've posted it in three parts.) Hopefully this has the necessary information. Please let me know if there's anything else you need.





Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,310 Points 10k badge 2x thumb
Ok, from what I can see from those screenshots, the DNS is very outdated. Please update the DNS to reflect this:

    A RECORDS

Name           Points to

mx            66.96.142.50
mx            66.96.142.51
mx            66.96.142.52
pop           66.96.135.134
imap          66.96.135.134
smtp          66.96.135.134
mail          66.96.135.134
webmail       66.96.135.48
email         66.96.135.48
@             108.167.135.85

    CNAME RECORDS
   
Name           Domain Name

 *            websites009.homestead.com
www           websites009.homestead.com
 m            mobile.dudamobile.com

    MX RECORDS
   
Host Type          Click to Configure-Mail Server          Priority

@                                mx.ctcparty.com                         10

 TXT Record

Host Type    Value

@                 v=spf1 ip4:38.113.1.0/24 ip4:38.113.20.0/24 ip4:65.254.224.0/19 ?all


The Cloud for the www and @ (your domain) should be turned on (Orange)
All other Clouds to the right of the DNS should be grey (off)

Please make these changes.
Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb
Thanks very much, Elyzabeth. With your kind help I feel like this problem is close to being resolved.

I've made the changes you mentioned, hopefully correctly. A test e-mail I just sent to info@ctcparty.com got the same error message, but that may just be that the changes (made only a few minutes ago) haven't taken hold yet. Below is the updated DNS report. Have I understood correctly the changes you called for? I was especially unsure of whether adding the new MX record for ctcparty.com (mx.ctcparty.com, priority 10) meant I should have deleted the previous MX record configurations.

Thank you for your help, and for your patience.


Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb
Great catch, Drew. Thanks. I've made the correction.
Photo of Drew N

Drew N, Community Manager

  • 258,852 Points 100k badge 2x thumb
I see the IP showing now on a lookup. There is a good chance it will work now, but propagation does happen over time. It doesn't get everywhere at the same time.
Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb
That's great news, Drew. Thanks. I'll send some test e-mails periodically over the next 48 hours and see what happens.
Photo of Bennett3683

Bennett3683

  • 324 Points 250 badge 2x thumb
Looks like the test e-mails went through, Drew. Sincere thanks to you and Elyzabeth for your efforts in resolving this.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,310 Points 10k badge 2x thumb
I'm very glad that it is working!

This conversation is no longer open for comments or replies.