I have outgoing links to bigcommerce on my homested site, how to secure both homestead and bigcommerce?

  • 0
  • 1
  • Question
  • Updated 1 year ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archiving inactive conversations.

Homestead site has outgoing links to items in my bigcommerce shop. I've followed the cloudfare instructions to change the name servers in the homestead part but then all of my bigcommerce links are 404. I need both to be secure.  
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
  • concerned

Posted 1 year ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
Hey Danni2136

I did respond to the question you posted in the main HTTPS article, but that has a LOT of comments so it is possible that was difficult to find. I would recommend settings your BigCommerce store SSL through BigCommerce.


https://support.bigcommerce.com/articles/Public/BigCommerce-SSL-Certificate/?q=SSl&l=en_US&fs=Search&pn=1
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
Thank you. I have followed the instructions and the bigcommerce store is secure. How do I go about securing the homestead site as well? I did try the other instructional but all of the outgoing links (bigcommerce) did not work after I changed the nameservers. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
At this point, I would follow the Cloudflare instructions once more to get the Homestead site secure, since both of them need to be. I believe the links had issues because both the homestead site and big commerce weren't both secure.
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
So after making the bigcommerce store secure, it still doesn't show my whole store as secure. Only the main page. Once I start clicking on different categories in my shop it shows as unsecured. The address in the browser does not automatically have https:// in front of it. Once I manually type https:// in the address bar it does show as secure, but bigcommerce does not offer a way for me to edit each link (at least I don't know where to find that option). You can check my site majesticventcovers.com and click on shop then click on the other categories. I think if I were to follow the cloudfare instructions at this point, all of those unsecured pages would be 404. Is there any way you or another rep can log in to my account and fix this for me? I don't want to cause anymore damage. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
Hey Danni, sorry. There is one more step in BigCommerce I forgot to tell you. Please do this:

Store Setup>Store Settings> HTTPS

and change it to "Use HTTPS for the entire site"

Then, do the Cloudflare set up, but when it pulls your DNS, you will see one for your store. There will be a cloud to the right. Make sure to turn that cloud OFF

If you would feel more comfortable, you can call in regarding this. I know it is more complicated than most have to deal with. 800-710-1998
(Edited)
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
thank you for the quick reply. That did work for the entire bigcommerce site. I will go ahead and use cloudfare on my main site and will let you know if that doesn't do the trick. Also, for anyone else looking, it's under Store Setup>Store Settings>website> HTTPS
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
Ah thank you for that correction.
And yes, just please remember, in step 6 when it is pulling your DNS and asks you to confirm, turn off the cloud next to your record for your store.
(Edited)
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
Hello. I do not see one for my store. The only two clouds I am able to turn off are the majesticventcovers.com (type a) and one that is a cname and says: "www" and "is an aliance of website055.homestead.com". However, I am able to add a record?  
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
You are able to add a record and should if you compare your DNS against what is currently in your Homestead account and any information doesn't match.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
For example, if it isn't showing a stores CNAME, you need to add it as it appear in the DNS in your Homestead account. That might be what caused the issues the last time.
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
Okay. So I see the cname for my store under the dns settings in homestead. Should I add a record for this and turn off the cloud if it gives me that option? 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
Yes, that is correct. Add any records that are missing and correct any that need to be edited.
It should give you the option to turn the cloud off for the store CNAME
(Edited)
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
okay. I'll try tonight, in case the links go down again. I'll check back if it doesn't work. Thanks.
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
Hi again. So I've add the stores cname and turned the cloud off, so far all the outgoing links are working. I'm assuming it takes some time for my site to show to https in the address bar. There is an option under "crypto" for: "Always use HTTPSRedirect all requests with scheme “http” to “https”. This applies to all http requests to the zone." It is off, is this something I need to turn on for my site? It still shows as not secure. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
You will turn those two options on when you are able to go to https://(yourdomain) and it comes up. Once it loads when you go to the https version, you can turn those settings on and it will do it automatically.
(Edited)
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
Hello. So it was not showing as secure until I turned on that option. Now both my store and main site are secure. Thank you for the help. Now, my last issue is my mobile site (through duda as suggested by homestead) there is no way to secure the mobile site through them, do you have any suggestions? Can I add it through cloudflare somehow? 
Photo of Danni2136

Danni2136

  • 926 Points 500 badge 2x thumb
The cname for the mobile store is in cloudflare under DNS, but the cloud is gray and says DNS only when I however over it. Will turning on the cloud do the trick?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,936 Points 20k badge 2x thumb
Unfortunately, we can't guarantee DudaMobile sites will work with Cloudflare. You can certainly test whether that works for your mobile site tonight, if you want to wait until there is less traffic.

This conversation is no longer open for comments or replies.