I can send emails but am not receiving them.

  • 0
  • 1
  • Problem
  • Updated 1 month ago
  • Acknowledged
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Inactive Conversation

On Wednesday, August 14, 2018, I set up my account for our website with Cloudflare. As of Thursday, August 15, 2018 I am no longer receiving emails to my email account. I can send emails out but am no longer able to receive them.
Photo of Rebecca4459

Rebecca4459

  • 230 Points 100 badge 2x thumb

Posted 1 month ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
Hello,

In your Cloudflare account, please make sure your DNS includes all of these records for the email:

https://community.homestead.com/homestead/topics/what-dns-records-are-needed-for-homestead-email

Is this trouble you are experiencing through Roundcube or a 3rd party program like Outlook?
(Edited)
Photo of Rebecca4459

Rebecca4459

  • 230 Points 100 badge 2x thumb
Elyzabeth, it is through Roundcube. According to our Pastor (who has been gone since the beginning of the month), she isn't actually showing anything new in her inbox since August 4.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
What is the email address in question?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
There are no MX records connected to this domain. The email wouldn't be able to work. Here is the step from the Cloudflare set up related to this:

6) Compare the DNS records Cloudflare scanned to your existing DNS records. They should match. If they do, click Continue.

If they don't, you can click on the name or value inside of Cloudflare that is incorrect and edit it. If you need help viewing your current DNS records, please see our topic, How can I view and edit my DNS records using Homestead nameservers.



NOTE: Please make sure to verify that the MX record has been added inside of CloudFlare's DNS settings. If you do not see a record with MX next to it, then we will need to add the MX record.


Click MX in the drop down, then click Name and type @, then Click to configure just right of that box. It will open a new window, please confirm your MX record.
If you are using email with Homestead, for server you will add mx.YOURDOMAIN.com, and for Priority you can put 10. Click save, then click Add Record.
Photo of Rebecca4459

Rebecca4459

  • 230 Points 100 badge 2x thumb
Also, how do I go about checking my DNS?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
This would be in the Cloudflare account. You would need to pull the DNS up in that account, and compare to the DNS in the article I posted.
Photo of Rebecca4459

Rebecca4459

  • 230 Points 100 badge 2x thumb
I did find the DNS section and made some manual changes in cloudfare. However, I'm still not receiving emails.
Photo of Rebecca4459

Rebecca4459

  • 230 Points 100 badge 2x thumb
I believe I have everything entered correctly now. However, I am still not receiving emails.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
You need to replace the "yourdomain" in the MX record with your domain name.
Photo of Marc7250

Marc7250

  • 236 Points 100 badge 2x thumb
This fixed my email problem - thanks Elyzabeth!!!  Ann
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,016 Points 10k badge 2x thumb
I'm so glad!

This conversation is no longer open for comments or replies.