I am not able to get the website editor to open. All that I am getting is a blank screen.

  • 0
  • 2
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

Unable to edit website.  I have logged into my account on homestead.com and brought up the website manager.  It is not loading correctly and I am not able to edit my site.  I am not able to get in to it at all.  I have logged in through 2 different browsers thinking that may be the trouble but that has not worked.  
Photo of Koren4075

Koren4075

  • 132 Points 100 badge 2x thumb

Posted 1 year ago

  • 0
  • 2
Photo of Diane9771

Diane9771

  • 80 Points 75 badge 2x thumb
I had the same problem, and it has happened before when Windows updated their system. See this page for the repair. It worked for me. https://community.homestead.com/homestead/topics/windows-10-and-sitebuilder-desktop
Photo of Todd H

Todd H, Social Media Specialist

  • 20,064 Points 20k badge 2x thumb
Hi Koren4075, I see you are editing a website inside of the new Website Builder editor. Are you still experiencing issues connecting into the editor?
Photo of Drew N

Drew N, Community Manager

  • 259,680 Points 100k badge 2x thumb
Click the menu button at the top right of your browser. There will be an option there that will say New incognito window(Chrome) or New private window(Firefox)
Photo of Koren4075

Koren4075

  • 132 Points 100 badge 2x thumb
That did not work.   This is the image on my screen when I open it. 
And this is what I get when I click to Edit Site.  
Photo of Drew N

Drew N, Community Manager

  • 259,680 Points 100k badge 2x thumb
You may need to add homestead.com and editor.homestead.com to your security exceptions. Maybe your security program is blocking you from getting to the editor. It loaded right up for me. What security program do you use?
Photo of Koren4075

Koren4075

  • 132 Points 100 badge 2x thumb
It has a couple of them on it because it is encrypted. If it is that I will have to contact IT to change those settings. I am not authorized.
Photo of Drew N

Drew N, Community Manager

  • 259,680 Points 100k badge 2x thumb
I think it would be the next step, to at least have them tell us that you should be able to get there or not.

This conversation is no longer open for comments or replies.