I am being billed for 3 domains when I only have two.

  • 0
  • 1
  • Problem
  • Updated 7 months ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

Transferred a domain to another site and the last was successful but grandtribe.com was not. Now I am being billed for it when I never successfully transferred it and chose another name.
Photo of Jay4497

Jay4497

  • 130 Points 100 badge 2x thumb

Posted 7 months ago

  • 0
  • 1
Photo of Drew N

Drew N, Community Manager

  • 259,004 Points 100k badge 2x thumb
I see that and we can get it fixed for you. Are you using that 3rd domain for the Homestead site? Do you want to try to transfer it again? Do you want to point it?
Photo of Jay4497

Jay4497

  • 130 Points 100 badge 2x thumb
I am not using that third site. I tried to remove it but I couldn't.
Photo of Drew N

Drew N, Community Manager

  • 259,004 Points 100k badge 2x thumb
I removed the failed transfer domain and charge. The system showed the transfer attempt in late August of last year. I have provided 7 months credit to the account for the domain. That will be subtracted from the next bill.
Photo of Jay4497

Jay4497

  • 130 Points 100 badge 2x thumb
Thank You for the correction, research of the issue, prompt service and replies. Couldn't ask for better service.
Photo of Drew N

Drew N, Community Manager

  • 259,004 Points 100k badge 2x thumb
You are very welcome.

This conversation is no longer open for comments or replies.