HTML5 Video uploads - No video just sound on Google Chrome & Firefox

  • 0
  • 1
  • Question
  • Updated 8 months ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

HTML5 Video uploads - I tried uploading a video with the HTML5 Options. The video would play perfect in Safari & Internet Explorer. Does not play video (only sound) in Google Chrome & Fire Fox. Using youtube at the moment but would like it to be hosted on my site.
Photo of Jessica9844

Jessica9844

  • 110 Points 100 badge 2x thumb

Posted 8 months ago

  • 0
  • 1
Photo of themieleman

themieleman, Champion

  • 57,192 Points 50k badge 2x thumb
Have you tried to use the You Tube embed code when using the HTML option?
https://community.homestead.com/homestead/topics/can_i_add_an_html5_video_to_my_site.
Photo of Jessica9844

Jessica9844

  • 110 Points 100 badge 2x thumb
I have youtube embedded currently as a temporary fix. I don't want to use youtube at all. The issue of youtube after the video plays it starts to suggest other videos that have nothing to do with me.

I want my video to be the only thing that shows up on this site which is why I was uploading it directly onto homestead but the HTML5 video does not play properly in Google Chrome or Firefox.
Photo of themieleman

themieleman, Champion

  • 57,192 Points 50k badge 2x thumb
If you have the video's html code, you'll be able to embed it unless there's some irregularity with the code. Perhaps Drew can examine your code and give you the answers you're seeking. He'll be on this asap.
Photo of Jessica9844

Jessica9844

  • 110 Points 100 badge 2x thumb
Embedding a file is not the issue. As mentioned it played perfect on my iPad, iPhone, Safari on a Mac and Internet Explorer on Windows.  When I tried to play it in Google Chrome on the Mac and FireFox on Windows the video would show a embedded player but no video would actually play.

I'm including pictures of the process used to add the video,
Photo of themieleman

themieleman, Champion

  • 57,192 Points 50k badge 2x thumb
Embed your html video code using More > HTML.
Photo of Drew N

Drew N, Community Manager

  • 258,538 Points 100k badge 2x thumb
Hmmm. I added the mp4 using the video player and it showed fine in preview. Did you make sure to refresh the page when you tried?
Photo of Jessica9844

Jessica9844

  • 110 Points 100 badge 2x thumb

I tried embed the video the above image is on Google Chrome the sound plays but no video the bottom screen shot is in safari video plays perfect.  Same issue works great in Internet Explorer does not work in Firefox.


The code I tried using is below hopefully it displays.  


<video width="320" height="240" controls>
  <source src="js2.mp4" type="video/mp4">
Your browser does not support the video tag.
</video>
Photo of Drew N

Drew N, Community Manager

  • 258,538 Points 100k badge 2x thumb
I will look at the reason code may not be working, but can you view your siteerror404 page? I added the video using the video player and it works for me in all browsers. Can you tell me if it works for you?
Photo of Jessica9844

Jessica9844

  • 110 Points 100 badge 2x thumb
I've done site error check in the past but cannot recall how. How do I do this?  My issue is in Google Chrome and Firefox. 
Photo of themieleman

themieleman, Champion

  • 57,192 Points 50k badge 2x thumb
siteerror404 page is listed on your page list.
Photo of Todd H

Todd H, Social Media Specialist

  • 19,954 Points 10k badge 2x thumb
Jessica9844, you can view your Site Error 404 here. Does the audio load for you?

This conversation is no longer open for comments or replies.