How do I specify the image used by Facebook for shares and likes?

  • 3
  • 26
  • Question
  • Updated 1 month ago
  • Answered
  • (Edited)
Note: We want to provide a few common and useful snippets for your use, but our support department is not able to assist you with editing code. They can help you with code placement.

If you want to specify what image is used when someone shares/posts/likes your website on Facebook you can add this snippet of code to the tag:
<meta property="og:image" content="http://www.domain.com/image.jpg"/>
Make sure you have already uploaded your image and published it.
Your picture will look best if it is square and at least 600 pixels wide
You just need to change the URL in the code to the address of the published image you want to use. In Sitebuilder Plus, the header area to add the code is located under Page Settings in the Advanced Settings.
After you've added the code there and published you will need to run your website URL through the Facebook Debugger so they will crawl the site and make the update.

Facebook Debugger
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb

Posted 5 years ago

  • 3
  • 26
Photo of Rick2837

Rick2837

  • 132 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Wong image displayed with website link.

When I send someone my website by e-mail, text or pm, an image of a business that I am no longer affiliated with, is displayed next to my website. How do I change this?
Photo of Todd H

Todd H, Social Media Specialist

  • 19,984 Points 10k badge 2x thumb
I can help update this if you can provide me the image you want to show when shared.
Photo of Rick2837

Rick2837

  • 132 Points 100 badge 2x thumb
This one would be fine.  I would like to be able to change it in the future.  Is that possible?  thx
Photo of Todd H

Todd H, Social Media Specialist

  • 19,984 Points 10k badge 2x thumb
It has been changed. If you want to change this, update the picture URL inside of your Page Settings within the script.
Photo of CJ8679

CJ8679

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled When someone posts my website url how do I choose what images shows in the previe....

When someone posts my website url how do I choose what images shows in the preview on facebook?
Photo of Jennifer8077

Jennifer8077

  • 172 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Website thumbnail not appearing on Facebook and other social media?.

When I share my we address on Facebook for example a really weird theumbnail shows up that’s unrelated.
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
Jennifer8077, You have no image for Facebook to choose to display. You will need to specify one.
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Lead Graphic for my website.
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
I updated my page settings tag but still no picture
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
Marlowe9222, Which site?
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
Facebook, Instagram etc
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
Which of your sites are you working on? Did you make sure to publish the image you are trying to use?
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
Still working for me:

<meta property="og:image"
content="http://www.septimiusthegreat.com/DSCN5524.jpg"/>
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
oops - still not working for me. I ran the FB debugger for www.septimiusthegreat.com and still show a gray color only and no image
Photo of Jerry0824

Jerry0824

  • 234 Points 100 badge 2x thumb
I finally got it to work!  This is what I put in.  See below.  You have to be sure that you have published it on Facebook first.  See second image.  Hope this helps!  I've been working on it for weeks (off and on), and could never get any simplified instructions.


(Edited)
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
Marlowe9222

I do not see an image named dscn5524.jpg in your file manager. Keep in mind that the image needs to be in your file manager and published. I also do not see the code in the head section in Sitebuilder. Using this tag is only a suggestion to Facebook as well. We can't force them to use an image. The image should be one that is published on the home page.
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
oops, I just updated the picture dscn4424.jpg 
Photo of Marlowe9222

Marlowe9222

  • 192 Points 100 badge 2x thumb
let me know
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
I am not sure why it took so long, but the Facebook debugger now shows the same as you have in the code.
Photo of Shirley2900

Shirley2900

  • 432 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled How to set preview image for Facebook?.

When I send a link to my site in Facebook, it comes up with a couple images, which are not appropriate. How can I set the image that's associated with my site link? I've seen some posts about editing the header file, but not sure how to do that...
Photo of Jerry0824

Jerry0824

  • 234 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled How do I set the picture that is shared when my website is mentioned on social me....
Photo of Jerry0824

Jerry0824

  • 234 Points 100 badge 2x thumb
OK.  I went to "Page Settings", then to "Advanced Settings" and put in http://www.3BFarmsBeef.com/facebookad.jpg   I made sure that the "facebookad.jpg" picture was in File Manager.  What goes in the spaces labeled "JavaScript (onload)" and "JavaScript (onunload)"??  
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
You need to place the URL inside of the HTML code.

Replace that URL with yours. Keep the quotes, then publish.

Then click the Facebook debugger link in the original post.

<meta property="og:image" content="http://www.mydomain.com/facebooklogo.jpg"/>
Photo of nicki6935

nicki6935

  • 100 Points 100 badge 2x thumb
Where is file manager located with the new site builder? I am unable to find the actual address (URL) to any of the photos I have uploaded.
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
nicki6935 I replied in your Image URL topic.
Photo of Jerry0824

Jerry0824

  • 234 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Can anyone give me SIMPLIFIED instructions on how to set the picture when someone....
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
This is about as simple as I can make it, but if you get stuck, just let me know where and I will take a look to see what is happening.
Photo of Jerry0824

Jerry0824

  • 234 Points 100 badge 2x thumb
OK.  Here's what I have on my site.  What goes into the other two spaces?
Photo of Drew N

Drew N, Community Manager

  • 258,974 Points 100k badge 2x thumb
That should be fine. Did you go to the Facebook debugger and enter your URL to see if it can scrape the image?
Photo of Darryl3174

Darryl3174

  • 194 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled Social Media Post Picture.

When I post onto social media a page from my website, the picture displayed to readers is not one of my images on the page but rather a square that is a solid color. It may be the background color for my page on my website. Please use an image instead.
Photo of Linda8325

Linda8325

  • 580 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled emailing link of my website's address.

When I type my website address in an email to send it to someone, a "picture box" pops up. It looks like it's trying to say that something wasn't done properly. But I don't know what this "box" is called or how it's created. When I've typed in other website addresses, It usually shows some of the first page of their sites.

Here's what it looks like:

Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,474 Points 10k badge 2x thumb
Hello Linda8325

If you scroll up to the original post I put your question on, you'll see the instructions you need. I know it talks about Facebook specifically, but after the cache clears, it also fixes that issue with your email.
Photo of Linda8325

Linda8325

  • 580 Points 500 badge 2x thumb
I put the code on the Index page, and it worked, but not right away. I didn't notice that it was fixed until the next day. However, when sending an email link, I see that if I type in the address for another page (like About Us, for example), I still get the "weird box." Seems like I need to put the code on each page if I want a real photo from that page to show up. What do you think about doing that?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,474 Points 10k badge 2x thumb
Yes if you are sharing other pages, I would put that code on all pages.
Photo of Victoria4017

Victoria4017

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled change thumbnail that displays with website link.

When i put my website link in an email to share my website with someone a thumbnail show up at the bottom of the email. How do I change the thumbnail picture that attaches when I add a link to my website.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 14,474 Points 10k badge 2x thumb
Hello Victoria4017

If you scroll up, you'll find instructions on how to change the image used for previews. The instructions specifically mention Facebook, but I've seen it work for the email as well. Once you finish the instructions, it may take some time for it to update and work.