How do I publish my pages?

  • 0
  • 5
  • Question
  • Updated 2 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

To publish your pages



Click Websites Manager on the left, then click Edit Site to go to the editor.




Steps to take


  1. Go to the toolbar and click Publish.





  1. In the Publish Pages & Files window,click one of the following:

  • Click This page to send the current page and all associated files to our servers.
  • Click Entire Site to send all open pages and associated files to our servers.

Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb

Posted 5 years ago

  • 0
  • 5
Photo of Keller0851

Keller0851

  • 222 Points 100 badge 2x thumb

and what do you do when that doesn't work?


Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
new topic Please reference the new topic here: Pages won't publish
Photo of Elizabeth3306

Elizabeth3306

  • 132 Points 100 badge 2x thumb
I have tried everything but standing on my head while publishing and it doesn't work.  I've been with Homestead for over ten years and it is no longer the company it was. I notice that many of the tools are no longer available and things simply don't work.  At one point, when I was searching for an answer, I was taken to an upgrade page.  Sure I want to spend over $400.00 more a year for an upgrade on a program that doesn't work.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Hi Elizabeth3306,   Sorry for the confusion and frustration. First, there is no need or reason you need to upgrade your account. I'm not sure what you were looking at or what led you down that path.  As for your website, I logged into your account and took a look at the file manager and all of your pages are indeed published.  

If you are seeing something on your live site, that is different than what you are seeing in SiteBuilder please tell us what page it is, and what we should, or should not be seeing, and we'll be happy to help you out. 


Mike 
Photo of Steve0692

Steve0692

  • 524 Points 500 badge 2x thumb
Mike
this is steve
when I try to publish a page, i get the message that the page was publish.  I also get a message that it was published to christiansareforever.homestead.com.  How do i publish my pages to my website, christiansareforever.com and not to your website.  I checked the file manager and the pages are listed as published but their not on my site.
Thanks
Steve Moys
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Hi Steve0692,  You are just seeing your Homestead subdomain. That is the same site your domain name is associated with so it's publishing to the right place. 

Mike 
Photo of Keith5805

Keith5805

  • 120 Points 100 badge 2x thumb
I have exactly the same problem.. but can't find anyone who has an answer to it.. I have also been with homestead for more than 15 years.. and now I can't change things on my pages and publish the new changes.. what is wrong with site builder.. this shouldn't be happening.. I have tried everything and nothing works.
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Keith5805,

Everything is up and running. Exactly what is happening for you? Do you see an error of any kind?
Photo of Keith5805

Keith5805

  • 120 Points 100 badge 2x thumb

Thank you.. I just checked and publishing seems to be working now.. maybe there was just a delay seeing the changes... but it is too late to work on my site now.. I will get back to you if I have publishing problems again.

There is another problem I can't fix.. There is a large white square blocking out the top of my index page.. but it is not visible in site builder.. and I never put it there.. so it must be a glitch on homestead itself.. and its ruining my index page.. could you remove it .. please..

http://www.apocatastasis.net/

(Edited)
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
This is not a glitch. When positioned where it is, the cause is HTML code that is in your head tag. Go to page settings and Advanced settings. Remove or repair the code in the head section.
Photo of Keith5805

Keith5805

  • 120 Points 100 badge 2x thumb

Thank you for your advice but.. I have never tampered with HTML code.. so how could it get there.. without me doing any thing.. My site was fine for 15 years.. until recently.. when that white square suddenly appeared.. and I know for sure it is not there because of anything I have done with HTML

I don't understand how to repair HTML code.. my computer knowledge is only basic everyday use..  so I can't fix it.. but I have to get rid of it because it is spoiling my site index page.. so what can I do? 

Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
The code is an embedding for a Youtube video that doesn't seem to work. Go to page settings, then the advanced tab. In the head section just remove the code in that box and publish the page. Your video is done on the page, so it won't be affected.
Photo of Keith5805

Keith5805

  • 120 Points 100 badge 2x thumb

Thank you Drew.. I removed the vid and the problem is fixed.. I will try another vid instead.

Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Glad to hear it.
Photo of Kaye4892

Kaye4892

  • 212 Points 100 badge 2x thumb
Drew, I am sorry to bother you, but my pages don't have the same kind of headings your screen shots have and I am unable to follow your wonderful directions because I don't know where to look. Too bad we can't do a screen share so you can see what I see. Also, the saved page for Reading looks fine in homestead when I save and publish, but then when I am not on the Homestead site, it doesn't show any of the additions I placed on the page. I used to be able to make these changes quickly and go about my business. I am not sure why the process is not working any more. I pay more for Site builder Plus and don't feel I am getting the same quality service with the program. Now, YOU are a different matter. You have been so nice to try to help me and I wish I could transfer your advice to my screen. Thanks...
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
So, your navigation menu is directing a visitor to pricelessliteracyhomestead.com/Reading-Centers.html. You have 2 pages that might be the correct URL, pricelessliteracy.homestead.com/ReadingCenters.html or you have a different page that is, pricelessliteracy.homestead.com/Reading.html, which is the one I am guessing is correct.

To fix it, click on your menu as pictured, and then on the right side, click on links.


Highlight the link you need to update, then click edit link.




Use the browse button to get to the list of files.



Select the page you want. I used reading for this example, then hit OK.



Then publish.
Photo of Mary Ellen7774

Mary Ellen7774

  • 60 Points
When I try to publish my changes to the site I get an error message that I'm not logged in?????
Photo of Kimara0309

Kimara0309

  • 162 Points 100 badge 2x thumb
Help-
I had 2 pages that previously were published now I get a not found message. What happened?
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
I don't see any page not found on your site. Which pages are missing?
Photo of Kimara0309

Kimara0309

  • 162 Points 100 badge 2x thumb
I was able to figure it out after 20 minutes.  This is what I get for renaming a page therefore the link was all wrong. 
Photo of Julie1487

Julie1487

  • 60 Points

I published my page it shows me the preview, but when I try to go there it doesn't come up. I have 2 websites, one works just fine and this new one isn't.


Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
The www sub domain was routed incorrectly. I have fixed it, but it may take up to 30 minutes to resolve.
I have the same problem balacademuskoka.com
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Patricia and Paul3893, We replied to you in another topic.
Photo of Althea4109

Althea4109

  • 92 Points 75 badge 2x thumb
Event page won't publish
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Your account allows for 5 pages. You have 6. Siteerror404 does not count against your total and should remain on the site. You can remove a page or you can add 10 pages for $2/month.
Photo of itstarka7780

itstarka7780

  • 60 Points
my site won't publish at all! It's saying "Error processing SSI file"
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
All pages are showing as published. You may have had a cache issue. Do you still see a problem?
Photo of divaboywear0067

divaboywear0067

  • 116 Points 100 badge 2x thumb
When I go to my website it ask if the domain is mine.  And says I need to reactivate my account.  I published it three times.
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
I believe we have this resolved now.
Photo of divaboywear0067

divaboywear0067

  • 116 Points 100 badge 2x thumb
Thank you so much but I have one more issue.  Now that its published and I can go on the site.  How do I find the rest of my pages?  It's only the home page that's showing up.  This web builder is a little more confusing than the first one I built with.
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Add a site navigation element to the header and it will replicate on all pages. Any new page is automatically added. You can remove it from the menu on the Pages tab

This conversation is no longer open for comments or replies.