How can I fix a "page not found, 404 error code?

  • 1
  • 63
  • Question
  • Updated 2 years ago
  • Answered
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

Photo of Scott5673

Scott5673

  • 660 Points 500 badge 2x thumb
  • frustrated!

Posted 7 years ago

  • 1
  • 63
Photo of marimath248116

marimath248116

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Stuck on Page One.


I have 3 pages, when I'm editing the pages I get all 3 pages but when I publish only the home page will show; I cannot use the navigation to go to page 2 or 3
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Hi marimath248116, I took a look at your site and the links in your navigation menu are not linked to any pages. If you follow the steps above, you'll notice that in step 3 you have not linked the text to any actual pages.

If this post helps, please give a "Star" and complete this survey to rate me.

Thanks!

Mike
Photo of William8246

William8246

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Problem updating web pages from Homestead or Intuit sites..


Every time that I post any page to my website, I get the error:

404 - File or directory not found.
The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

The page updates on the website but I have to back out and log in again to do any further updates. The website works fine. This is the first time that I have done any updates since your cut on 9/11. I don't know if that has anything to do with it.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
This may be the issue. Follow this thread: https://community.homestead.com/homes...
If you are experiencing something different let me know.

Mike
Photo of Troy8291

Troy8291

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Links No Longer Work...Help.


I just updated my website (just cosmetic and reformatting data) and now the links on my main navigation bar do not work. Any idea why?
Photo of shelly7363

shelly7363

  • 92 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
help me with problems i cant fix on my web site pages.


please help me with my website pages...some are reporting ( site air) and also one the main page it shows a Skype symbol on my business phone number we have listed. it is www.splitendssalonandspa.com
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The site error messages are caused by broken links which you can troubleshoot using the steps here.   The skype symbol is caused by a browser addon installed on your computer. It's a click-to-call feature that converts phone numbers to the skype symbol.
Photo of muyfamiliar87873

muyfamiliar87873

  • 164 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
Help, I only can publish my index or home page.


Help, I only can publish my index or home page
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Your pages are publishing ok, but you are linking to invalid page names. Follow the instructions here to troubleshoot.
Photo of showhomes2122

showhomes2122

  • 156 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
My third page isn't showing.


My third page shows up as 'under construction' in the old domain name. Also, I want my main URL to be www.presentationsells.com. it's currently realhomemakeover.com
Thanks for your help.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
I was able to change the primary domain from this end. To fix the page issue, you just need to correct the navigation link. There's a typo in your link. If you refer to step #3, this is where you'll need to fix the spelling.
Photo of Carlene6223

Carlene6223

  • 152 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
Return to Home Page from another Page...error message...How do I fix Link?.


My website: www.candltreeservice.net has an issue. Please advise "How to fix the problem where you are on a different page, other than the Home Page....click on Home Page expecting to return to Home Page, and it says there is an error." The only way to return to Home Page is to search for the website again and start over. Thank you in advance :) I am sure it is an easy fix I am overlooking.
Photo of Don8873

Don8873

  • 84 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
suddenly my menu doesn't take me to the correct page ... help!Donl.


My site were working now they are not responding correctly what have I done? How do I fix it?
Photo of Carlene6223

Carlene6223

  • 152 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
My pages do not link back to my Home Page. Please advise, in detail. I would greatly appreciate it!!! www.candltreeservice.net.


I've read the instructions and cannot figure out how to make the pages link back to the Home Page.
Thank You in Advance!
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The home page of every site is the "index" page. So, if you follow the steps above, when you get to #3, just connect the Home link to the page named "index.html", republish the site and it will be fixed.

Mike

Photo of breezie5608

breezie5608

  • 80 Points 75 badge 2x thumb
Thank you so much! This helped me out big time! You are a life saver!
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
Glad to hear it.
Photo of Steven2964

Steven2964

  • 234 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
404 on 5th Page I'm paying for?.


I was told when my fee went up to the full basic price that I'd have five full pages to fill up. Lately, I've noticed that my 5th page doesn't work but has instead turned into a 404 page. I'd like to have that last page so I can use it to put up a nice contact wrap up appeal w/o losing more photo space.
Photo of Nyri7101

Nyri7101

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Upon clicking the link on the edit page they appeare correctly; However, when I go into preview mode my links are showing error page.


upon previewing my links my service links will report as SITE ERROR and my partners link will go back to stating owner, then when I re-click on my service link it will appear the way I originally have it but then when I click on the OWNER link it turns back into Partners but blank.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Take a look at step #3 in this thread. You created the links, but the page names are invalid.

Mike
Photo of Arndt6626

Arndt6626

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
404 ERRORS.


ATTENTION DILLON, transition dept; Received this message from Google - apparently my site was crawled and the fixes you made are not sufficient to correct the errors. Please call me asap regarding your next step.

Increase in not found errors

Google detected a significant increase in the number of URLs that return a 404 (Page Not Found) error. Investigating these errors and fixing them where appropriate ensures that Google can successfully crawl your site's pages.
Photo of Susan Lisk

Susan Lisk

  • 132 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
published webpage comes up sorry page you are looking for cannot be found.


site is published and ok in manager but comes up with above. Also cleared my cache.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Your site seems to be working now, but if not follow the steps above. If you are still stuck and can't find the problem, let me know which links and pages you are having the issue with.

If this post helps, please give a "Star" and complete this survey to rate me.

Thanks!

Mike
This reply was created from a merged topic originally titled
please help me.


Hi my second page is no longer showing once link is clicked what did I do I cannot find it did I delete it ? www.greennationprocessors.com , the page is titled grease vs. environment
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The page has not been deleted so it's just a matter of reconnecting the link to the right page as shown above.

mike
Photo of corylamb214849

corylamb214849

  • 122 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
Website Not Found.


When trying to go to my website http://www.gospelmanifesto.com/, I keep getting an Error 404 message. That domain is supposed to pull up my homestead site "CoryMLamb", but all i get is the error message.
Photo of wyont8310

wyont8310

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Problem with my menu links..


After publishing my website, I have found that the last three buttons are not linked. I have tried to relink them, but it still not allowing me to open the pages when I go to my website. I just agreed for the site to be announced on Facebook. I would love to get them repaired.
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The first thing to check is that there's not a text box, or some other transparent element layered on top of the links. Then, the steps here will help you identify any broken links and how to fix them.

Mike
Photo of Barbara7564

Barbara7564

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled
Enabling a 5th page on the site.


When editing my site, I can see a page (Seating Chart), but when I publish and open it on the internet I cannot open this page. What can I do. I only have 4 other pages and this should be my 5th page.
Photo of charles4787

charles4787

  • 132 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
how do i get navigation page links to match the View Page names? (I changed the names of the pages.).


I changed the page names and now the names I have on the pages do not match the page name links. If I direct someone to the page named Freeport Triathlon, then I have to tell them to go to www.healthyhabitstri.com/firm rather than www.healthyhabitstri.com/freeport_tri...
Photo of Milton7919

Milton7919

  • 192 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
My new page I just added, saved, and published does not show. It goes to "sorry, the page you're looking for can't be found.".


Just added a page to the webite. When I use another computer to access it, I get a page that says, "sorry, the page you're looking for can't be found."
Photo of Stella5352

Stella5352

  • 342 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled
Editing navigation bar.


Problem editing navigation bar. I updated a link (Smith/Biars) but it isn’t showing up in the real world. The change is necessary because I had to build a new page to replace one that was corrupted and couldn’t be edited. Summing up: need help linking Smith/Biars on the navigation bar to the new page http://wva.homestead.com/GeorgeSmithJ... West Virginia Memories: http://wva.homestead.com/
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
Use the steps on this page.
Photo of Alan Davidson

Alan Davidson

  • 296 Points 250 badge 2x thumb
This reply was created from a merged topic originally titled
Cannot upload new design.


I have 5pp only. I've just spent all day changing my design. An error in keying had me getting error 404 coming up. It meant it looked like I went to a 6th page. I didn't. I urgently need to upload these new pages but am told to contact you. AlanDavidsonPublicity.homestead.com. in Australia. Can you please fix this error for me?
Photo of daryn61644198

daryn61644198

  • 112 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
Web page problem.


I have created a home page, photo gallery page and products page, have saved them all and have published the entire site. For some reason when people go to my URL they are only able to view the home page and gallery page. Whats the problem?
Photo of lesleygaudet5796

lesleygaudet5796

  • 82 Points 75 badge 2x thumb
Photo of morris9890

morris9890

  • 152 Points 100 badge 2x thumb
This reply was created from a merged topic originally titled
Can't save page.


I can't get a page to appear on my site. I have saved and published several times. toughcartsbuilder.com is the site. 5 Drum Frame is the page
Photo of Mike F.

Mike F., Alum

  • 184,678 Points 100k badge 2x thumb
The page is actually published and working fine. The problem is with the navigation link. Follow the steps above and when you correct link/page name, and republish the site it will fix the problem.

Mike

This conversation is no longer open for comments or replies.