How do I get internal links to work?

  • 0
  • 1
  • Problem
  • Updated 6 months ago
  • In Progress
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

I was originally told by Technical Support to create the mobile version of my existing Homestead desktop website by adding/editing elements in the desktop mode.  I thought internal links worked, but now they don't in Preview. 

Perhaps website links only work if "Attach Link" for "Website Page" is never checked to open in a "New Tab".  Sounds crazy to provide an option to destroy links.  But is that what happens?

I recall now that the links worked before I went to Open in a New Tab.  The problem remains that otherwise there is no "BACK" command I'm aware of for return to my Home/Index Page, where all the links are.  That "BACK" command is an absolute necessity for any website.

Seems the Website Links now fail regardless of what choice I make, having or not having them open in a "New Tab".

I simply should not receive these absurd error messages for opening links in a New Tab: 

"Oops, it looks as if an invalid Homestead URL was entered." and "Oops! This link appears to be broken."

I'm wrecked.    Something is badly wrong, either with "Preview" or else with Website Builder.

Has to be a solution, but what is it?. 

I need help.

Dave

Photo of David Mundstock

David Mundstock

  • 100 Points 100 badge 2x thumb

Posted 6 months ago

  • 0
  • 1
Photo of Todd H

Todd H, Social Media Specialist

  • 19,814 Points 10k badge 2x thumb
Which website are you working in? If this is an error that is showing in Website Builder I certainly want to get this reported.
Photo of David Mundstock

David Mundstock

  • 100 Points 100 badge 2x thumb

Todd,

I lack the experience to label my difficulty as an error vs. a problem.  The links don't work as described.  But there must be an obvious solution related to how "Preview" is different from the real thing.  Otherwise the answer could be creation of new links.  Don't know, which is why I asked for help.  With Technical Support closed on Sunday, I hoped for a quick fix.  No such luck.

But today I will call Technical Support and become educated in how internal links actually work.

So I don't believe there is anything to report, and decline to waste more of your time.  Thanks for being the only one who replied.

Dave

 

Photo of David Mundstock

David Mundstock

  • 100 Points 100 badge 2x thumb
Turns out that Website Builder is incapable of doing a real preview, which I did not know.  It only recognizes one tab.  Internal links will work when published.  So says Homestead Technical Support.
Photo of Todd H

Todd H, Social Media Specialist

  • 19,814 Points 10k badge 2x thumb
The preview is completely internal and yes some features inside of the preview will not work. After publishing is when we would be able to do a proper test for anything we see not supported inside of preview.

This conversation is no longer open for comments or replies.