How can I add unique HTML Meta and Link tags on each web site page? I now can only apply the same HTML to all page s on the site.

  • 0
  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

I am currently using Website Builder. I want to add some HTML Meta and Link tags to the pages on my site. I have a unique set of HTML I want to add to each page. I have tried using the Pages / Settings / Page Meta Tags option but the HTML I add never ends up in the source code for the page (which I validate through a Chrome browser with the right click "View Page Source" option.)

I have also tried the option to add an embedded HTML element with my HTML Meta and Link tags, and this doesn't generate the source code on the page either.

I then added the HTML Meta and Link tags through the Manage / Advanced Settings /Site Meta Tags option. This does generate the tags in the source code...on each page.

However, I want to generate unique tags for each page, and not one set of tags for all pages. How can I do this?

Thanks.
Photo of Sean3096

Sean3096

  • 274 Points 250 badge 2x thumb

Posted 2 years ago

  • 0
  • 1
Photo of Drew N

Drew N, Alum

  • 262,676 Points 100k badge 2x thumb
I am not sure what exact tags you are trying to add, but you may go to Manage > Advanced and uncheck the Ajax navigation box. Then go to page settings and add the code to the header html for each page.
Photo of Sean3096

Sean3096

  • 274 Points 250 badge 2x thumb
Hello Drew,

I am interested in adding Meta tags for Twitter and Facebook card properties.

I specifically did what you suggested. After doing this, I checked the source code within the Chrome browser and could see that the WebBuilder system put the meta tag HTML within a Javascript snippet in the source code. The net effect of this is that it made the meta tag HTML unrecognizable as if it was just documentation. I know this because I would test the web page URLs on the tools provided by Twitter and Facebook for debugging purposes. The tests always produced errors because the tools would never be able to find the appropriate meta tags. So I then took the HTML out of the WebBuilder interface for inputting the tags on the page specific site and put it into on the overall web site by using the Manage /Advanced option. It would then work.

Sean
Photo of Drew N

Drew N, Alum

  • 262,676 Points 100k badge 2x thumb
I am discussing this with the development team now to see if they can explain what is up.
Photo of Sean3096

Sean3096

  • 274 Points 250 badge 2x thumb
Thanks! Let me know if you need any further clarification.
Photo of Drew N

Drew N, Alum

  • 262,676 Points 100k badge 2x thumb
Will do.
Photo of Sean3096

Sean3096

  • 274 Points 250 badge 2x thumb
Hello Drew,

Is there any update on this issue?
Photo of Drew N

Drew N, Alum

  • 262,676 Points 100k badge 2x thumb
Unfortunately there is not at this time. I did send it to the development team.

This conversation is no longer open for comments or replies.