Google browser will not recognize my site since I added the free SSL. . .

  • 0
  • 1
  • Question
  • Updated 11 hours ago
  • Answered
The google browser will not recognize my website ironmanarmor.com (IronManArmor.homestead.com). It redirects to the generic Homestead page since I added the free SSL on cloudflare. 
Photo of Mitchell12

Mitchell12

  • 190 Points 100 badge 2x thumb

Posted 2 weeks ago

  • 0
  • 1
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
Hello Mitchell12

I see the domain pointing failed for ironmanarmor.com when it was added last year. As far as the homestead website can tell, there is only the sitename IronManArmor.homestead.com and those cannot be secured through Cloudflare. I will delete and re-add the domain for you to try to get that working, but it depends on if the DNS is correct in Cloudflare.
Photo of Mitchell12

Mitchell12

  • 190 Points 100 badge 2x thumb
That is not correct. It has worked fine until I added the Cloudflare.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
I'm sure it worked previously because you had the domain redirecting to the site name, but nothing I said was incorrect as I just listed facts from the account.

Your domain pointing failed. That is a fact, as it was surrounded by a big red box that said "pointing failed" in your domain tab. I deleted and re-added it to help you fix that issue.
It was only showing the site name, which cannot be secured through Cloudflare.
The DNS needs to be correct in Cloudflare for it to be able to point to our Homestead site and work.

The only thing I can suggest is to contact the company you have your domain registered through to remove the URL pointing. Also, log into your Cloudflare account and take a screenshot of your DNS tab. Post it here and I will tell you what needs to be corrected.

On another note, I believe it is only your Chrome browser that can't pull up your site because it is working on my computer and all of my coworkers, as well as my phone using Chrome.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
The detailed walkthrough is here:

https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https

You cannot secure the site name .homestead.com because that is a subdomain of Homestead and you do not have access to that. They are secure, but do not automatically redirect to https://

Most people have domains either registered through Homestead or pointing to Homestead. If you do not, then you cannot use our instructions to secure the site because the instructions do not apply to you. You would either need to point your domain name to Homestead or talk to the company you are registering/hosting your domain through to get it secure.

If you have any other trouble, I would recommend calling in. 800-710-1998
Photo of Mitchell12

Mitchell12

  • 190 Points 100 badge 2x thumb
It is still showing as unsecured on Google Chrome after this change. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 12,160 Points 10k badge 2x thumb
It looks to me like when I go to https://www.ironmanarmor.com/, the site pulls up. This means it is set up, you just need to finish the last few steps. Go into the Cloudflare account, click on the Crypto tab, and turn on the setting for "Always use HTTPS" and "Automatic HTTPS Rewrites".
I would also recommend republishing your site.