Form Submission Problems

  • 0
  • 1
  • Question
  • Updated 6 years ago
  • Answered
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members.

I have been having problems with the form submission not coming through to my personal email address. It normally comes through fine, but I wondered why business was so slow, so I filled out and sent several forms from my website to myself.

I only got 1 of them???

My whole business is reliant on my webiste and its form submission.

Help!!!!!

Note: This topic was created from a reply on the April 12, 2013 - Email issue impacting customers using Outlook topic.
Photo of Richard8083

Richard8083

  • 174 Points 100 badge 2x thumb

Posted 7 years ago

  • 0
  • 1
Photo of Mike F.

Mike F., Alum

  • 184,698 Points 100k badge 2x thumb
Hello Richard, There can be a number of things causing this issue. I see you have a very large number of websites. If you can re-post and let us know which site and what page the form is on, we can take a close look and I'm sure we can help you out.
Photo of Richard8083

Richard8083

  • 174 Points 100 badge 2x thumb
The website I am having issues with is www.artschoolnz.com

This is incredibly worrying as 99% of our business comes through the submission forms.

I have just tried sending from them again and nothing!!!

Please fix this as soon as possible!!!
Photo of Mike F.

Mike F., Alum

  • 184,698 Points 100k badge 2x thumb
Thanks for providing me that information.

I noticed that the form submission (at least on the home page) was going to your xtra.co.nz email address. After looking deeper I see that you have the mx records shown below, which is Yahoo, not Homestead (tucows). Be sure to check your Yahoo junk, spam folders to see if the emails are there.



Your safest option would be to use a different email address. We have recently seen some cases where Yahoo is completely blocking the form emails.

Mike
Photo of Sean2311

Sean2311

  • 180 Points 100 badge 2x thumb
Hi

I am having the same problem. I have just checked my stats and see that a number of enquiry forms have been submitted, however I have received none! When I fill in the form on various pages they come through OK. Again my business is reliant on these enquiries.
A month or so ago the contact us button didnt work at all and you fixed it. My site is
apartment-rentals-fuerteventura.com
Photo of Mike F.

Mike F., Alum

  • 184,698 Points 100k badge 2x thumb
I see you have over 50 sites. What is the site and page with the form you are having the problem with?
I am having the same trouble. How do I find where the form is to go once submitted?
Photo of Mike F.

Mike F., Alum

  • 184,698 Points 100k badge 2x thumb
When you are in SiteBuilder, click on the form. Then look to the right and you'll see a field with the email address. By default it auto-fills the email address which was used when your account was opened up, but you can change it to any email address you wish.

If this post helps, please give a "Star" and complete this survey to rate me.

Thanks!

Mike

This conversation is no longer open for comments or replies.