e-mail address is showing instead of name of company on search engines

  • 0
  • 1
  • Problem
  • Updated 3 months ago
  • Solved
Merged

This conversation has been merged. Please reference the main conversation: What are page titles and descriptions?

When I go to Google my website shows the e-mail address instead of the Name of the company. How can I get this fixed? 
Photo of carolinefisher03753

carolinefisher03753

  • 112 Points 100 badge 2x thumb

Posted 3 months ago

  • 0
  • 1
Photo of Todd H

Todd H, Social Media Specialist

  • 19,954 Points 10k badge 2x thumb
Which website is it so I can take a look?
Photo of carolinefisher03753

carolinefisher03753

  • 112 Points 100 badge 2x thumb
Photo of Todd H

Todd H, Social Media Specialist

  • 19,954 Points 10k badge 2x thumb
Load into the WebsiteBuilder editor, then click Pages at the top left. Click Manage Pages, then find the "Title" option. You will see you have your email address right here already, go ahead and change it to what you want your title to be, then click Save.

This conversation is no longer open for comments or replies.