Cannot verify server idenity... HOMESTEAD'S certificate expired 4/11/19 !!!!!! therefore can't get email !! Please correct !!

  • 5
  • 28
  • Problem
  • Updated 5 months ago
Merged

This conversation has been merged. Please reference the main conversation: Email login 4/12/2019

MESSAGE"  CAN NOT VERIFY SERVER IDENITY... HOMESTEAD'S CERTIFICATE EXPIRED !
Photo of Scotti9239

Scotti9239

  • 440 Points 250 badge 2x thumb
  • angry !

Posted 5 months ago

  • 5
  • 28
Photo of Damon2314

Damon2314

  • 184 Points 100 badge 2x thumb
Same page. I have 10 emails setup
Photo of thadine5180

thadine5180

  • 92 Points 75 badge 2x thumb
I am having the same issue 
Photo of Jennifer3209

Jennifer3209

  • 580 Points 500 badge 2x thumb
I am having this same problem!

Photo of Kimberly4798

Kimberly4798

  • 150 Points 100 badge 2x thumb
I"m getting this to and in the middle of working! Please let me know if you figure out how to correct! 

Photo of Ruth4676

Ruth4676

  • 122 Points 100 badge 2x thumb
The Same thing is happing to me as of the last 30 minutes!

Photo of jeff4552

jeff4552

  • 60 Points
Same issue let's fix the problem homestead
Photo of Jennifer3209

Jennifer3209

  • 580 Points 500 badge 2x thumb
I can't even access the HMail web interface.  Our emails are unaccessible and they are closed for the day!

Photo of Jessica5481

Jessica5481

  • 176 Points 100 badge 2x thumb
So, this is a Homestead issue, and now we are all sitting ducks??
Photo of Jeff8905

Jeff8905

  • 124 Points 100 badge 2x thumb
You can check it through the unsecure route - that's how we had to get ours.
Photo of Jennifer3209

Jennifer3209

  • 580 Points 500 badge 2x thumb
How do you do that?  My phone keeps giving me an error and I cannot access the webmail interface at all. 
Photo of Amy4099

Amy4099

  • 184 Points 100 badge 2x thumb
I had to do it via my laptop. I ended up deleting my mail accounts on my iphone because it was driving me crazy while I was trying to get work done. 
Photo of Stefanie0379

Stefanie0379

  • 232 Points 100 badge 2x thumb
That was my solution, too. Delete the account on iPhone and access via computer. Had to override security settings to "ignore" the unsecured connection.
Photo of Amy4099

Amy4099

  • 184 Points 100 badge 2x thumb
I am having the same issue as off about 1 hour ago or less for both of my 2 accounts. It says my email is not private and though i was able to finally access it, there is an error everytime and my iphone wont stop saying its having issues with the server access.
Photo of Judith5800

Judith5800

  • 260 Points 250 badge 2x thumb
I am also having the same email problems!! It’s 11:30 pm (EST)!! What is going on????
Photo of Charlie5147

Charlie5147

  • 90 Points 75 badge 2x thumb
same here
Photo of S

S

  • 6,760 Points 5k badge 2x thumb
same issue
Photo of Juan6567

Juan6567

  • 150 Points 100 badge 2x thumb
Any word from Homestead Support?
Photo of Wendy0517

Wendy0517

  • 60 Points
me too same thing
Photo of Scotti9239

Scotti9239

  • 440 Points 250 badge 2x thumb
Homestead hasn't updated their message blog in looks like ...years !!  Can't get thru to anyone as their offices are closed until 6AM PST !   This is totally ridiculous and unacceptable !!!


Photo of Amy4099

Amy4099

  • 184 Points 100 badge 2x thumb
They posted in late February of this year actually. Maybe not the regular blog but the server/website issues blog, they've posted.
Photo of Scotti9239

Scotti9239

  • 440 Points 250 badge 2x thumb
Amy4099 .... this  post in Feb has absolutely NOTHING to do with what we are all experiencing tonight...  Who gives a crap about a post back in Feb that is totally not relative.   Thanks @Q 
Photo of Scotti9239

Scotti9239

  • 440 Points 250 badge 2x thumb
I bypassed the messages and can receive emails .... what you have to do is allow your computer to accept Homestead without credintuals...
Photo of Damon2314

Damon2314

  • 184 Points 100 badge 2x thumb
May have a workaround if using your phone its the ssl certificate that you can toggle off, that will then bypass their lack of having a valid certificate. Sorry only found it for iphone:
Disable SSL on Iphone

Click on Settings
Click on Mail, Contacts and Calendars
Under Accounts Select your Email Account
Click on your Account again
Scroll to the bottom of the account screen and click on Advanced
Scroll to the bottom and under Incoming Settings Use SSL turn that off
Make sure Authentication is set to Password
Click on <Account in the upper left hand corner
Click Done again
Now you click to go back to your home screen
Photo of Dominic5867

Dominic5867

  • 64 Points
this worked for me although I think its ridiculous it came to this. I have iphone 6 plus.

Photo of Tamara7636

Tamara7636

  • 134 Points 100 badge 2x thumb
Can't thank you enough for the SSL toggle instructions. Between my iphone & ipad  those warning messages were driving me batty. It's unbelievable that a business whose main purpose for existence is web sites, domains and email lets their SSL license expire. Not a good look, Homestead.   
Photo of Bill6863

Bill6863

  • 130 Points 100 badge 2x thumb
Thanks for the workaround. I guess we all just wait to see what the Dutch folks do about the overall problem???
Photo of Thomas8165

Thomas8165

  • 114 Points 100 badge 2x thumb
Thanks for your help with this. I went to bed last night assuming they would have this fixed by this morning.  This "temporary?" fix will get me through the day.
Photo of Jennifer3332

Jennifer3332

  • 124 Points 100 badge 2x thumb

Same problem.  Ugh!  All of my work comes through emails from the federal courts.  PLEASE fix this asap.  I'm losing money by the minute.
Photo of elizabeth8274

elizabeth8274

  • 100 Points 100 badge 2x thumb
same thing. please fix and let us know ASAP

Photo of Scotti9239

Scotti9239

  • 440 Points 250 badge 2x thumb
When the message comes up on the computer screen... it will ask you if you want to continue to use the server... just click yes ...you are by passing the computer's trust settings...  if that doesn't work go into your computer settings and allow Homestead's certificate .
Photo of John7796

John7796

  • 142 Points 100 badge 2x thumb
same issues, this is a business account and needs to be fixed ASAP!
Photo of Sabrina3973

Sabrina3973

  • 240 Points 100 badge 2x thumb
SAME! FIX. THIS. ASAP PLEASE!
Photo of Vandi6305

Vandi6305

  • 100 Points 100 badge 2x thumb
I had to delete all the homestead email accounts off my phone because the constant error message was driving me crazy! They need to fix this ASAP!
Photo of Kimberly4510

Kimberly4510

  • 112 Points 100 badge 2x thumb
Work around on iPhone - turn off BOTH SSL settings in Incoming & Outgoing. On Mac computer - I clicked "show certificates" and entered my computer password and it fixed it. 
Photo of Sales0349

Sales0349

  • 194 Points 100 badge 2x thumb
THANKS !! 
Photo of Kaila0460

Kaila0460

  • 72 Points
I  tried this on my Mac and it directed me to RoundCube Webmail. I enter my username and password (same as always and it says "invalid"). Anyone else experience this?
Photo of Dave2503

Dave2503

  • 130 Points 100 badge 2x thumb
how do you turn off both ssl settings in incoming & outgoing?  I only see the one SSL in the advanced settings.
Photo of Richard

Richard

  • 344 Points 250 badge 2x thumb
HELLO I NEED THIS FIXED ON COMPUTER...

Photo of Kaila0460

Kaila0460

  • 72 Points
I  tried this  (On Mac computer - I clicked "show certificates" and entered my computer password) on my Mac and once bypasses it directed me to RoundCube Webmail. I enter my username and password (same as always and it says "invalid"). Anyone else experience this?

So frustrating and completely unacceptable!

This conversation is no longer open for comments or replies.