Auto SSL for Website Builder- Pointed Domain

  • 0
  • 2
  • Article
  • Updated 6 days ago
  • (Edited)
If your domain is pointed to Homestead (not registered through Homestead), then you will need to activate the SSL we provide. To do this:

Click on the Domains tab
If it is pointed correctly, you will see "Activate SSL" to the left of your domain options.

Click that link



This will bring you to a page with 4 step instructions
  1. Log in to your domain hosting provider
  2. Locate the DNS management section in your domain hosting control panel. If your domain is pointed via nameservers, you will click "Advanced DNS Settings"
  3. Add an A Record for *your domain* that points to *IP address*
    *This should be done for the "@" record and the "www" record*
  4. Once the 'A record' Has been modified, Click Next.




A message will pop up verifying that the DNS settings are correct and your SSL will be provisioned soon. 




Please wait 24-48 hours for this change to take effect.
Photo of Homestead FAQ

Homestead FAQ, Employee

  • 42,506 Points 20k badge 2x thumb

Posted 10 months ago

  • 0
  • 2
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
There are 3 A records for the new builder. *, @, and www. Which one do we change?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
@ and www should be changed.
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
How long does this take to take effect? I did it last week
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
Hello,
Typically it takes no more than 24 hours.

Did you go back to the "Activate SSL" page after you updated the DNS and click "Next" and get the message that the SSL will be provisioned soon? If not, please go do that now.
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
I did. I just did it again, so I'll wait and see.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
What domain are you working on?
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
turekdigitalmedia.com
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
Still nothing. Anything else I need to do?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
Since your domain isn't registered with Homestead, I cannot double check those settings. Can you post a screenshot of your DNS from your domain registrar so I can check it?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
Ok, I will submit a ticket to get this resolved. Your A records look fine.
Photo of Jonathan T.

Jonathan T.

  • 6,374 Points 5k badge 2x thumb
This got completed now. Is there anything I did wrong for the future? or was it something on your end ?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 43,634 Points 20k badge 2x thumb
This happened because the domain on this site was changed. It shouldn't happen every time, but if you have any issues please let me know.
Photo of Becky4048

Becky4048

  • 82 Points 75 badge 2x thumb
This reply was created from a merged topic originally titled Our website monarchplastics.com is showing as not secure. How do we secure it?.

Our website monarchplastics.com is showing as not secure.  How do we secure it?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb
Please follow these instructions to secure your domain
Photo of susan2829

susan2829, Champion

  • 43,192 Points 20k badge 2x thumb
"A" record changed 4 days ago, but SSL is still not provisioned.  Site in question is saintmarysmission.org
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb
After you changed the A records, did you go back to the Activate SSL screen and click "Next" so our system could check for that change?
Photo of susan2829

susan2829, Champion

  • 43,192 Points 20k badge 2x thumb
yes and got the message that it had been changed., but it doesn't show in the browser.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb
OK, thank you, so you've done everything that needs to be done on your end. I will create a ticket to get this resolved. It should be working within 24 hours.
Photo of susan2829

susan2829, Champion

  • 43,192 Points 20k badge 2x thumb
thank you. :)
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb

Happy to help. I'll check it in the morning too, to make sure it updates.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb
Hey Susan,

I just wanted to check back in with you. Unfortunately, this ticket hasn't been responded to yet. I'm sorry for the inconvenience, but we will have to push the expected resolution time to Monday. I will check back in on Monday
Photo of susan2829

susan2829, Champion

  • 43,192 Points 20k badge 2x thumb
Ho Hum  :(
Thanks for letting me know Elyzabeth.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,060 Points 20k badge 2x thumb
This domain is now showing as secure!
Photo of susan2829

susan2829, Champion

  • 43,192 Points 20k badge 2x thumb
Wonderful. :)  TY
Photo of cathyjsutton9421

cathyjsutton9421

  • 90 Points 75 badge 2x thumb
I have followed the information above dealing with Pointing the domain and getting secure on my website. When I do the information above this is what I get:::

Sorry, you have experienced an unexpected server error.

You have experienced an unexpected server error. We are working to resolve this problem as quickly as possible. Please try again later.

Don't know what I am doing wrong. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 41,270 Points 20k badge 2x thumb
Hello,

At what point are you getting that error? (what are you clicking that directs you to that error message?)
Photo of cathyjsutton9421

cathyjsutton9421

  • 90 Points 75 badge 2x thumb
I type in at the @ the new numbers a tech person gave me and when I submit it that's what I get. I go to domains, then advanced dns settings. I edit the top one - @ to the numbers I got from a tech person to get it pointed correctly and then submit button twice and then I get that message. 
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 41,270 Points 20k badge 2x thumb
Ok, this might have been a temporary error or an issue with the browser. I did not get this error, but was able to update the DNS for you. The SSL will be provisioned soon
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
Elyzabeth is there away to get my domain hosted by Yahoo to show as secure?  Yahoo claims this service is coming but that has not materialized yet.  My domain points to my homestead website.

Thanks,
Rich
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
Hello,

If you have your domain pointing to Homestead Website Builder site but is registered with another company, you can follow the instructions in this article to get your site secure.
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
Hey Elyzabeth I started the process but it appears this is a bit over my head.  I started task 1 and it appears to be ready.  Here are the screens I see on my domain registers page.  Not sure what to do next?

Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
any help you can provide would be awesome. thanks

Rich
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
Hello Rich!

You just need to update the "@" A Record and "www" A record to the IP address from the "Activate SSL" link in your account. I am not familiar with Yahoo's DNS page, but they should have support that can help if you are having trouble getting those added!
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
When I click the activate ssl in my homestead account I get this message. "Domain cant be verified as it doesn't exist on builder".  The attached photo is a screen shot of the Yahoo DNS page.
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
I also think that because I have added cloudfare to my primary domain name registered through homestead that may be a problem?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
Ok, there are a couple things I need to talk about with your account. I can see that you have two domains attached to your WebsiteBuilder site. This is not allowed, only one domain can actually be connected to that site. I have moved the pointed domain off of the WebsiteBuilder site and pointed it to your domain registered with Homestead. Also, you don't need to go through Cloudflare to get a secure site, so if it is ok with you, I'll reset your nameservers back to Homestead so we can be in control of the DNS and can secure your site.
Lastly, are you using email through Yahoo for that domain? If not, it really would be easier to point your domain to Homestead via nameservers so we can edit the DNS through our account. If you are using email through Homestead, I need you to add different DNS than you currently have in there. Let me know which option you're going to go with so I can provide the proper records
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
Hey, thanks for your time. I wont get into the long story of why I have things setup like I do. My main goal is to have both domain names show as secure when visitors go there. So if you need to remove cloudfare that is fine. Also I do not use homestead or yahoo mail associated with these domain names.

Thanks again,
Rich
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
The way we would currently be able to set it up would be to have the .net on the WebsiteBuilder site, and to direct traffic from the .com to the .net. So, the site would be secure, but it will show the main domain, the .com, regardless of which domain is visited. That is how it is currently working, but it might take a few hours for that SSL to apply.

The .com domain is pointing to Yahoo. Would you be ok with editing that domain to point to Homestead nameservers so I could make the necessary corrections on my end? Since you are not using email with this domain, it should not cause any trouble.
(Edited)
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
The .com is still showing as not secure.  Did I misunderstand you by thinking both the .net and .com would show as secure?   I appreciate your help.

Rich
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
It isn't that you misunderstood, but my last comment asked if you would be ok with pointing that domain to Homestead via nameservers so I could make that happen. Either that or I need to give you DNS to update, but nameservers are easier.
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
Ok, I thought I responded to that. Yeah do what you need to do on your end. Thank you
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
Actually this is something that needs to be done on your end. You'll need to update the nameservers through Yahoo:

NS1.MDNSSERVICE.COM
NS2.MDNSSERVICE.COM
NS3.MDNSSERVICE.COM

These are our nameservers. If you make this change through Yahoo and let me know when this is done, I can fix the pointing domain.
(Edited)
Photo of Rich

Rich

  • 442 Points 250 badge 2x thumb
OK name servers have been changed in yahoo to the ones you provided :)  It appears it is working correctly!  If I go to the .com address it forwards to the .net which shows as secure!  I like it, that is what I wanted.  Thank you so much for sticking with me on this.  

Rich
(Edited)
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 38,194 Points 20k badge 2x thumb
Awesome, glad it is working!
Photo of Starla2088

Starla2088

  • 60 Points
I built a brand new site with Websitebuilder and redirected my domain name (hosted by Homestead) to point to the new site.  I think i did everything right, but the website is showing "not secured".  Reading this, it seems like SSL should be automatic.  Is there something special I need to do?

Thank  you!
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,314 Points 20k badge 2x thumb
Hello Starla,

The SSL typically is automatic, but sometimes it does require a small change on our end to get it working. I have made this change for your domain and the site will show as secure within 24 hours.
Photo of Steve Fama

Steve Fama

  • 70 Points
I don't see Active SSL?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 42,304 Points 20k badge 2x thumb
Hello,

Your initial site is automatically secure through Homestead, but then you have the domain redirected to a 3rd party URL, which is not secure.
Photo of Steve Fama

Steve Fama

  • 70 Points
Where did the Tech Support Phone Number Go?
Photo of Joey8748

Joey8748

  • 120 Points 100 badge 2x thumb
Elizabeth,

My website keeps trying to get me to have the nameservers pointed to Homestead, but I want to keep the DNS records on my registrar. Can you please help with this? My site is http:///www.jtocomputersolutions.com
I have been a long term customer since you all bought from Intuit.
Photo of Jay4952

Jay4952

  • 60 Points
I have the same issue, Don't see Activate SSL on the domain section. 

Photo of Michelle C

Michelle C, Employee

  • 3,356 Points 3k badge 2x thumb
Hello Jay, 

You will only see activate SSL if your domain is a pointed domain and you are using WebsiteBuilder. Since your domain is connected to a SItebuilder Plus site you will need to follow these instructions to add the SSL. https://community.homestead.com/homestead/topics/can-i-secure-my-homestead-website-with-https