Auto SSL for Website Builder- Domain Pointed via A record

  • 0
  • 1
  • Question
  • Updated 5 days ago
  • Doesn't Need an Answer
  • (Edited)
If your domain is pointed to Homestead, but you do not control the DNS through your Homestead account, this is how to apply the Auto SSL for Website Builder Sites. 

First, make sure your domain is pointed to Homestead via A record.

Click on the Domains tab
If it is pointed correctly, you will see "Activate SSL" to the left of your domain options.

Click that link



This will bring you to a page with 4 step instructions
  1. Log in to your domain hosting provider
  2. Locate the DNS management section in your domain hosting control panel
  3. Add an A Record for *your domain* that points to *IP address*
  4. Once the 'A record' Has been modified, Click Next.




A message will pop up verifying that the DNS settings are correct and your SSL will be provisioned soon. 




Please wait 24-48 hours for this change to take effect.
Photo of Homestead FAQ

Homestead FAQ, Employee

  • 41,656 Points 20k badge 2x thumb

Posted 4 months ago

  • 0
  • 1
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
There are 3 A records for the new builder. *, @, and www. Which one do we change?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
@ and www should be changed.
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
How long does this take to take effect? I did it last week
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
Hello,
Typically it takes no more than 24 hours.

Did you go back to the "Activate SSL" page after you updated the DNS and click "Next" and get the message that the SSL will be provisioned soon? If not, please go do that now.
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
I did. I just did it again, so I'll wait and see.
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
What domain are you working on?
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
turekdigitalmedia.com
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
Still nothing. Anything else I need to do?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
Since your domain isn't registered with Homestead, I cannot double check those settings. Can you post a screenshot of your DNS from your domain registrar so I can check it?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
Ok, I will submit a ticket to get this resolved. Your A records look fine.
Photo of Jonathan T.

Jonathan T.

  • 6,032 Points 5k badge 2x thumb
This got completed now. Is there anything I did wrong for the future? or was it something on your end ?
Photo of Elyzabeth

Elyzabeth , Official Rep

  • 27,736 Points 20k badge 2x thumb
This happened because the domain on this site was changed. It shouldn't happen every time, but if you have any issues please let me know.