audio clip is supposed to play immediately on homepage

  • 0
  • 1
  • Question
  • Updated 3 months ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: 7 days of inactivity

When my homepage opens, an audio clip is supposed to play immediately and continue in a loop while the page is open. It used to work this way, but why must I click on the icon"home" to get it to play automatically?
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
  • frustrated

Posted 3 months ago

  • 0
  • 1
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
Hello,

You may need to use the updated audio player. Log into the editor and upload the audio clip into this element then make sure its set to auto play from the settings on the right.  

Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
I tried using the new media player but I ended up with 2 instances of the sound clip running at the same time, un-synced. I tried to find and remove the original sound clip, but I can't seem to find where it is embedded. Also, I can't download the full version of Sitebuilder because my PC stalls at trying to install netframework 3.5, it just won't install, so I have the same problem. The sound clip that used to play automatically and play continuously whenever my homepage was opened, now only plays if I click on the "home' button in the navigation menu.
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
If you are hearing it play twice there has to be a second audio player on the page somewhere. I can try to narrow down where it may be. This is on your home page correct? 
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
Yes, it is on the homepage (index)...I can't find where the original audio file is embedded so I can remove it and use the new audio player. I can't download the sitebuilder plus because the netframework 3.5 won't install. I also found the old audio file on a different pc, and I tried to remove it and use the new audio player, but I kept getting an error message saying that I need to be online to save changes and publish it. My PC is definitely online on that computer, but Sitebuilder doesn't recognize that it's online, so I can't make any changes that way.
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
It looks like johnnyangelentertainment.com does have audio playing through HTML on the home page you will see an HTML box in the editor.



 Sitebuilder plus does not need to be downloaded just log into your homestead account, go to websites manager and click edit site. 
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
Ok, so I deleted html-3 and added the new audio player and set it to play automatically and continue playing, but it isn't working like it used to, I still have to click on "home' in the navigation menu to get it to play, and it only plays once thru, not continuously...still not solved!
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
Looks like you used the old audio player. You'll need to use the one under YouTube, then audio player as shown in the image above. 
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
Ok, so I deleted the audio player and found the one hidden under youtube, selected the soundclip, selected all 3 boxes, play continuously and automatically, it still won't play automatically until I click 'home' on the navigation menu! Also, when I click on 'save' and then 'publish, it does not save it as www.johnnyangelentertainment.com, it saves it as www.johnnyangelentertainment.homestead.com. Why is that? Anyway, the sound clip won't play automatically and continuously, something else is wrong!
(Edited)
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
If I click on 'preview', it takes me to my homepage and the audio clip plays as expected. but if I 'save' and 'publish', then it does not, then I have to click on 'home' in the naigation bar to get it to play.
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
After looking into this further, unfortunately,  this is not something we have control over. Auto playing of audio files is automatically blocked by browsers now as they want to allow the viewer to choose to listen to the audio or not. Users can adjust settings to allow auto play but most people will not and just leave that as a default setting. https://developers.google.com/web/updates/2017/09/autoplay-policy-changes  The reason it plays when you click on home or go to another page and go back to home is because google has an engagement setting that will auto play when the customer performs activity on the site (clicking home). You can view that in their auto play policy here chrome://media-engagement/. I would also recommend not hiding the audio player for a better customer experience. I am sorry but we do not have a way to override browser settings you can attempt to convert the audio file to HTML and try to have that auto play but again its the actual browsers that are blocking the file from auto playing so i cannot guarantee that will work. 
Photo of Johnny Angel

Johnny Angel

  • 170 Points 100 badge 2x thumb
Well then why is is that when you navigate to some of my other pages, a different soundclip plays automatically? If it does it on other pages, it should do it on the home page as well.
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
It plays because you are engaging with the webpage. If you are on the home page and click on home, it will play because the user activation is required. 
Photo of Michelle C

Michelle C, Employee

  • 14,128 Points 10k badge 2x thumb
I do hear one audio file auto playing on the mullet festival page, whats happening and photo gallery. 

This conversation is no longer open for comments or replies.