404 error when trying to edit my site

  • 0
  • 2
  • Problem
  • Updated 2 months ago

This conversation has been merged. Please reference the main conversation: Reports of Server Errors 5/30/2020

After logging in, all pages on Homestead except the first design page result in a 404 error, meaning I cannot even open the website manager tab to edit my website. 
Photo of Matt4941


  • 110 Points 100 badge 2x thumb
  • Frustrated

Posted 2 months ago

  • 0
  • 2
Photo of themieleman

themieleman, Champion

  • 70,176 Points 50k badge 2x thumb
Let me know how this works for you.
To install the new page as your home page, select the page > Page Settings > Page Name > enter "index.html" > save. Remove the page name from your previous page.
Next, you can add the new home page to your site navigation menu by selecting the menu > Use the Site Navigation Menu Settings > Links > + to add the page > follow the instructions in the command box to locate your new home page > select the page from your files > OK. Now, you can scroll to the bottom and edit the page title. Since you have only one page, it should now be the only page on the menu and it should appear with the page title you've chosen and it will respond as the home page.
For Sitebuilder plus sites you can use the save as option and rename the desired home page index. https://community.homestead.com/homestead/topics/sitebuilder-plus-rename-pages