"my email address is rejected by the server" message when trying to send email from iphone

  • 0
  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Archived

I have deleted my account and re entered info based on trouble shooting provided to others with similar problem. This still does not work. It had worked for years, so I am a bit confounded.

Also, my work program uses my email account to send emails to customers. There have been no changes to that either but I cannot send emails any longer.

I can still log in through the website and send which goes through  with no problem.

I had already contacted help through chat and went through their suggestion of setting up anew

Photo of Debra9485

Debra9485

  • 414 Points 250 badge 2x thumb

Posted 3 years ago

  • 0
  • 1
Photo of Drew N

Drew N, Alum

  • 262,816 Points 100k badge 2x thumb
I have had a few iPhone users that were recently updated. The outgoing server had the user name and password removed. You'll need to go to the advanced settings and look at the outgoing mail server settings. Make sure there is no SSL, the port is 587, and make sure that smtp.homestead.com has the user name and password in the box. iOS shows it as optional. It is NOT optional. Let us know if that works. Deleting the account, as I recall, does not delete the outgoing server, so you may have more than one. If you see more than 1 smtp for Homestead, delete all but one and check the settings.
Photo of Debra9485

Debra9485

  • 414 Points 250 badge 2x thumb
Will run through those suggestions. Thank you
Photo of Debra9485

Debra9485

  • 414 Points 250 badge 2x thumb
I have performed the steps suggested and still I cannot send mail. I have even tried to change my password. I still get message that user name/ password for smtp.homestead.com is incorrect
Photo of Debra9485

Debra9485

  • 414 Points 250 badge 2x thumb
Okay. I upgraded to Hmail Suite. Deleted old email in settings on iPhone. Deleted old servers which were listed under my Yahoo account servers. Now I can send emails.

This conversation is no longer open for comments or replies.