Conversations

Photo of Martin
Sites are not publishing!
No doubt in my mind something is wrong on the HS side. Can someone please look into it. And no, it is not because my site is too "BIG". T...
  • 2 me toos
  • 3 replies
  • Problem
  • In Progress
  • Archived
Photo of Martin
Snails Pace
Site Builder Plus is running at a snails pace today. Anyone else? Folks at Homestead?
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
  • Archived
Photo of Martin
Email Problem
Drew, I added a new email account to my customautosbytim.com account and all seems normal....however I can only send, not receive. Thanks 
  • 1 me too
  • 2 replies
  • Problem
  • In Progress
  • Archived
Photo of Martin
Here we go again.....
Back to some of the same nonsense. Cant publish, placement of elements wrong, this would include text, pictures and HTML. What I do manag...
  • 1 me too
  • 3 replies
  • Problem
  • In Progress
  • Archived
Photo of Martin
Slow....
SiteBuilder Plus is slow as molasses running up hill on a cold day today, what is the problem?!?!?!?!?!?
  • 1 me too
  • 2 replies
  • Problem
  • Acknowledged
  • Archived
Photo of Martin
I need to be reimbursed!
Drew or who in the hell?I will need to be paid for my time!I paid for a service and have not received what I paid for several months! Thi...
  • Martin, 5 years ago

  • 2 me toos
  • 0 replies
  • Problem
  • Archived
Photo of Martin
Email!
You all have taken incompetency to a level never before seen in the history of Homestead! I have wasted more time, money and effort due t...
  • Martin, 7 years ago

  • 3 me toos
  • 0 replies
  • Problem
  • Archived
  • Merged