homestead_faq's profileBrand User

669 Messages

 • 

44.4K Points

Thu, Jul 18, 2019 7:26 PM

WebsiteBuilder: Sitemap

WebsiteBuilder: Sitemap
Homestead Websitebuilder creates and publishes the sitemap.xml file automatically for you. There is no longer a need to generate it and upload to the site. You can view your sitemap by going to http://www.yourdomain/sitemap.xml

Responses

28 Messages

 • 

872 Points

2 y ago

Hi!  :)

Is there a way to view the sitemap of an unpublished site? (A Websitebuilder site.)


16 Messages

 • 

270 Points

2 y ago

After a bit more investigation on the sitemap issue (my first post doesn't show yet). I see Homestead is using the generator at sitemaps.org. I used this service independently to check if it came up with differences, and there are a few. But, I noticed my homestead URLs are updating every page to the same <lastmod> date (today). I didn't change them all. Is this correct?

16 Messages

 • 

270 Points

2 y ago

I tried raising this issue with support. Unfortunately, I got a man who I don't trust to either understand the issue, understand the importance of the issue, or know how to elevate the issue. Usually I get a woman on the line and they've been uniformly great (and I am a man). So, I decided to document the issue here as I believe I'll get a better chance at response:

The issue pertains to Google Search Console and sitemaps generated by the new website builder. All my sites have been verified for ownership in the GSC. I also submitted the location (path and name) for the sitemaps and they show correctly in the GSC. But every page I inspected initially showed it wasn't indexed and that they were not submitted in the sitemap. I manually, individually submitted every page URL for indexing and that worked. Except the GSC now reports that they are INDEXED, NOT SUBMITTED IN SITEMAP and DISCOVERY: SITEMAPS N/A.

As you may imagine, to me this is a critical issue. Perhaps I don't understand what I'm looking at in the GSC. But seems wrong. Incidentally, I looked at the sitemaps and they appear correct, although I've seen other formats, so I can't verify correctness by inspection. I did see one issue, for my blog entries the lastmod date property is incorrect, defaulting to 2015-08-13 and I believe that is a problem and should also be fixed.

Here is a an image of what I'm seeing in GSC:
Brand User

7.6K Messages

 • 

106.7K Points

2 y ago

Hello,

If your concerns are in relation to it showing indexed, not submitted in sitemap. All you will need to do is select sitemaps from the left and submit the site map url which in your case is http://www.accessrite.com/sitemap.xml.

99 Messages

 • 

3.7K Points

6 m ago

I tried this and no site map for me.  How do I  find out if it is there for google submit.  

99 Messages

 • 

3.7K Points

6 m ago

I was going to assoc the DNS record with Google but it warned me that my email could be considered spam after that so I did not do it that way.