Skip to main content
Brand User

655 Messages

 • 

44.2K Points

Tue, Jul 16, 2019 3:44 PM

WebsiteBuilder: Rename Pages

There are two places that will allow you to edit the page name in WebsiteBuilder. 

  1. Log into the editor, click on Pages on the left menu, click the 3 lined "hamburger" menu next to the page name, and click "Rename"



    Type the new page name and click "OK"




  2. Log into the editor, click on Pages on the left menu, and click "Manage Pages" From this window you can click on the page you want to edit and change the Page name. 


Responses

17 Messages

 • 

1.2K Points

a year ago

I've just started a website using a template. I've changed the page names in the menu, but the old names still show up on the browser bar (e.g., page in menu is "photos", on browser bar is "Homestead Editor (about us)". Likewise, when I view the page on the internet, the name "about us" shows in the browser tab. How do I change the name in the browser tab? In all the areas shown above in steps 1 and 2, the name is the new one "photos".
Brand User

3K Messages

 • 

61.5K Points

Hello,

I see a lot of websites on your account. What website is this on? 

21 Messages

 • 

670 Points

YES!  I have the same issue.  I want the browser page name to show up different than "Home" or "Calendar" as labeled in the Website Builder.  Help!!
Brand User

3K Messages

 • 

61.5K Points

Hello,

For WebsiteBuilder sites, you can customize your page name, URL and title to show how you want. The page name is what will show in the builder and the navigation menu, the page url is what will display in the address bar when the page is visited and the page title will show in the window tab and on search engine results. They can all be the same or customized different, click on manage pages to edit these. 

17 Messages

 • 

1.2K Points

a year ago

The Sitebuilder site I'm trying to "copy" is http://www.boyntonbarber.com/. The new Website Builder site is at <a target="" rel="" href="http://www.boyntonbarber.homesteadcloud.com/" alt="" title="" name="" value="" type="">http://www.boyntonbarber.homesteadcloud.com/</a> http://www.boyntonbarber.homesteadcloud.com/.
Brand User

3K Messages

 • 

61.5K Points

Thank you. The page names match from the original site to the new one. It sounds like you are trying to attach the domain to a new site, you will need to change the site association for the domain boyntonbarber.com. Here are more detailed instructions. https://community.homestead.com/homestead/topics/how_can_i_switch_my_domain_to_a_new_site_i_built

17 Messages

 • 

1.2K Points

a year ago

I appreciate that link .. I'll need it later. I've changed the page-names in the browser header by saving a copy of each page with the correct (new) name.

Brand User

3K Messages

 • 

61.5K Points

Perfect, did that resolve your problem?

17 Messages

 • 

1.2K Points

a year ago

New problem: On the website I'm creating boyntonbarber.homesteadcloud.com, on the photos page, I've included a photo gallery. I currently have about 20 photos in the gallery, but only 12 are showing on the page. How do I get them all to show up?
Brand User

3K Messages

 • 

61.5K Points

No problem, from the editor click on the photo gallery, click on more>advanced>settings and increase + the items per page to reveal more photos. 


17 Messages

 • 

1.2K Points

a year ago

yes

17 Messages

 • 

1.2K Points

a year ago

done .. thanks

30 Messages

 • 

1.2K Points

a year ago

I am just learning how to use website builder.  So I have my pages named and the way I want them to be on my webpage, but I need the address to those pages to be different.  For example I have one page called "CPR & BLS Certification" but I don't want the address to page to have all that in it if I want to send someone directly to that page.  I want it to just say cpr or something simple like that so it is easier to share with people.  In sitebuilder it was easy to do that, but I cannot figure it out in website builder.
Brand User

3K Messages

 • 

61.5K Points

Hello,

You can do that by changing the page URL. Select pages and then manage pages. Un-check the box that says use name as URL then customize the page URL. Select save and that will adjust the URL.