K

1 Message

 • 

70 Points

Thu, Jun 10, 2021 6:24 PM

Web pages slow to load. How to troubleshoot?

Hi Team - 

My website and its individual pages seem to be loading very slowly.  When I go there I notice the circle on the browser tab rotating counter clockwise, as if it's waiting for something or trying to establish a connection, then after 5-10 seconds it starts rotating clockwise and the page starts to load.  Also the graphics are taking a long time to fill in on the individual pages.  

Any ideas as to how to approach this?  I noticed it yesterday on my phone and it's doing it today on my desktop as well.  

https://www.nobleschooljax.org/index.html

Thanks for any insights or ideas.  

Kevin G. 

Responses

Brand User

7K Messages

 • 

101.2K Points

9 d ago

Hello,

 

I apologize, this has been reported and we are investigating the issue. I appreciate the patience.

1 Message

 • 

62 Points

same here, thanks

9 Messages

 • 

150 Points

9 d ago

I'm having the same problem with https://www.drywallcarolina.com/ 

It took close to a minute to fully load on mobile and close to that long on desktop. On mobile I gave up waiting for a linked page to load but on desktop it loaded 40-50% very quickly and then came the wait. Once the linked page was fully loaded on desktop I could go to the previous page (index) quickly

Brand User

7K Messages

 • 

101.2K Points

Thank you I will add this to the report. We are currently investigating. 

9 Messages

 • 

150 Points

Thank you.

4 Messages

 • 

140 Points

9 d ago

This is also happening to my site...

Brand User

7K Messages

 • 

101.2K Points

Thank you for reporting, it is being investigated. 

3 Messages

 • 

150 Points

8 d ago

This problem is also happening on our site - problem started on June 10 and continues today.  Canadian Federation of University Women | Aurora, Ontario L4G 6S6 (cfuwauroranewmarket.com)

Brand User

7K Messages

 • 

101.2K Points

Thank you for reporting, we have escalated this ticket and it is being investigated and worked on. Apologies and thanks for your patience. 

1 Message

 • 

60 Points

8 d ago

Same for my 2 sites. Taking forever to load and navigate on the site. First noticed it 2 days ago.

Peter S.

Brand User

7K Messages

 • 

101.2K Points

Thank you for reporting, it is still being investigated. We will send an update as soon as it is resolved. 

9 Messages

 • 

150 Points

8 d ago

While I can't speak for the others who contributed to this thread, I can say that for me the problem appears to be resolved at this time. The desktop and mobile load and navigate as they should. Thank you for your help. It's truly appreciated. Thanks again.