dan_or_brad2150's profile

26 Messages

 • 

1.1K Points

Wed, Jul 21, 2021 12:55 AM

'noindex' detected in 'X-Robots-Tag' http header

I'm using the old site builder plus and I keep getting an error 'noindex' detected in 'X-Robots-Tag' http header when submitting to Google search console.

I'm not using a site map, I just inspected a URL directly and it always says it's being disallowed by a 'noindex file". I don't have a no index file and I've looked everywhere.  I thought it might have been imbedded in something so I started deleting elements. That didn't fix it. Finally  I made a brand new blank page called test with no content and it still gives me the error when submitting to google.

https://cabletvfinders.homestead.com/test.html

http://www.cabletvfinders.com/test.html

When I manage this on google it says

URL is not available to Google
It cannot be indexed.
VIEW TESTED PAGE
Page changed?
REQUEST INDEXING
Availability
Excluded by ‘noindex’ tag
URL will be indexed only if certain conditions are met
Discovery
Not checked in live tests
Crawl
Time
Jul 20, 2021, 7:41:06 PM
Crawled as
Googlebot smartphone
Crawl allowed?
Yes
Page fetch
Successful
Indexing allowed?
No: 'noindex' detected in 'X-Robots-Tag' http header
Indexing

This conversation is no longer open for comments or replies and is no longer visible to community members.

26 Messages

 • 

1.1K Points

1 y ago

I went into the robots.txt tester and this is what it says... "Block all bots from the core Homestead site"

# Block a bot that was causing issues by ignoring Disallow lines below
User-Agent: OmniExplorer_Bot
Disallow: /

# Block hotlinking of music files by projectplaylist.com due to perceived user bandwidth theft
User-agent: projectplaylist-directlink
Disallow: /

# Block all bots from the core Homestead site
User-agent: *
Disallow: /~site/Scripts_ElementMailer
Disallow: /~site/Scripts_ExternalRedirect
Disallow: /~site/Scripts_ForSale
Disallow: /~site/Scripts_HitCounter
Disallow: /~site/Scripts_NewGuest
Disallow: /~site/Scripts_RealTracker
Disallow: /~site/Scripts_Track
Disallow: /~site/Scripts_WebPoll
Disallow: /~site/siteapps/showmap.action

661 Messages

 • 

75.4K Points

1 y ago

You must have a landing page. Call it what you want.

To install the new page as your home page, select the page > Page Settings > Page Name > enter "index.html" > save. Remove the page name from your previous page.

26 Messages

 • 

1.1K Points

@themieleman

I have a home page. The No Index is referring to the command it's telling google to not index my pages in the search engine. This appears on all pages. 

Brand User

7.6K Messages

 • 

106.7K Points

1 y ago

Hello,

 

Unfortunately troubleshooting this is out of our scope of support. If you can call in at 1-800-710-1998 we may be able to direct you to the right place but I cannot guarantee.