Skip to main content
T

6 Messages

 • 

136 Points

Sat, Sep 5, 2020 10:01 AM

Customer Contact Form

We are Equal Ability Radio at www.bigearradio.com

 

Our customer feedback form has not been working for a couple of days.

 

Is anyone else having this problem and, if so, is it being attended to?

 

Many thanks

 

Trevor Krueger

Responses

258 Messages

 • 

71.2K Points

3 months ago

Review: https://www.123formbuilder.com/docs/i-enter-the-correct-verification-number-but-the-form-does-not-accept-it-why/

HELP
Hours of Operation for Live Support
Sales: 1-800-986-0958 (Support can also be contacted via this number)
Support: 1-800-710-1998
Mon-Fri: 6:00am - 5:00pm MST(No DST)
Sat-Sun: Closed

Captcha not working?

 
Please fill the required fields

5 Messages

 • 

110 Points

I had the same problem yesterday with my contact form.  I had to delete it with the website builder and add it again to the page.  That fixed it.

6 Messages

 • 

136 Points

Thanks very much, I'll do that. That's really helpful.

 

I appreciate your help!

 

Best wishes

Trevor

From the U.K.

5 Messages

 • 

110 Points

3 months ago

I have used an online form company for years.  They are Cognito Forms.  Their free forms program allows up to 500 submissions per month and, of course, if you need to be able to receive more than 500 per month they have a paid version.  The forms are very easy to create, or you can use their standard forms.  Once the form is created and you have entered the email address you want the form entries to be sent to, you simply have them generate an html code that you copy and paste into your web site.  8 years now and I have never had their forms fail.  Can't say that before I started using them.  Unfortunately Homestead support is not available weekends and Holidays.

Brand User

2.9K Messages

 • 

60.9K Points

3 months ago

Hello Trevor, 

The contact forms are functioning, it looks like the form is set to send submissions to trevorkrueger@btinternet.com. Have you checked this address for the submissions? 

6 Messages

 • 

136 Points

Hi Michelle,

 

My address hasn't changed, all my mail comes to that address, thanks for the suggestion but that would have been a schoolboy error to be fair.

 

However, thanks to the earlier advice of simply deleting the form and adding it again, I'm now all sorted and back to normal. It's funny how these occasional bugs occur, something must trigger them... I wonder what.

 

Thanks for everyone's help, it's all appreciated. It's easy to overlook an obvious silly mistake so it's worth checking anything that might help resolve a niggle.

 

Thanks guys...

 

Trevor

Brand User

2.9K Messages

 • 

60.9K Points

No problem, I would also suggest looking into using the new platform WebsiteBuilder, this will relieve some of those road bumps and bugs. However, glad it is working now. 

6 Messages

 • 

136 Points

Yes I will, trouble is I tried the new version before and really didn't like it. The okld version is simplistic but dead easy to use and you really can see and control what you are getting, so I returned back to the old version.

 

I'm going to watch the videos and see if it has been improved again. Progress and more features would be great, but only if it is as nice to use as the old platform. I found my last experience over complicated and much harder to use. I dropped that pretty quickly to be honest...

 

Fingers crossed the new version is better?

 

Trevor

Brand User

2.9K Messages

 • 

60.9K Points

There definitely is going to be a learning curve as there is with anything new but we do have video tutorials and are here to help it go as smooth as possible. Feel free to reach out with any questions you may encounter.